Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

've been struggling with Xming and putty for a while and I can't make it work; I enabled X11 forwarding in putty, updated xauth list on the client side with the xauth list of the server side. Currently I can run xclock from the client machine on the server machine when the DISPLAY is set to :0.0 (it shows xclock on the server machine), but I can't run it locally on the client machine; in other words, xming window doesn't pop up at all. I already changed the DISPLAY to localhost:0.0, myip:0.0, and none has worked, when I run xclock (when display is set to myip:0.0) it starts (I don't get "can't find Display" error) but still xming doesn't show anything. I'd really appreciate if you share your thoughts on this with me, Thanks in advance, P.S. in my sshd_config I have the following lines:

X11Forwarding yes

X11Displayoffset 10

X11UseLocalhost yes

Iman

share|improve this question
    
try xhost +localhost, temporarily. –  rackandboneman Apr 4 '13 at 15:28
    
is there actually an "xauth" binary on the local machine? –  rackandboneman Apr 4 '13 at 15:30
    
I am not sure if i got your question correctly, but xauth list on the local machine is the same as xauth list on the server now. –  Iman Apr 4 '13 at 15:37
    
xhost +localhost didn't fix the problem –  Iman Apr 4 '13 at 15:38
    
Try with no access control: straightrunning.com/XmingNotes/IDH_CLIPBOARD.htm –  Schrute Apr 4 '13 at 17:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.