Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have purchased an Intel i7 3770 and an Asus P8Z77-M Pro; for some Windows Server 2012 testing.

In the BIOS I have enabled the "Intel Virtualization Technology", and have several Hyper-V based virtual machines running.

I thought everything was fine; but hit an issue when trying to install Remote Desktop Services. It said that "Hardware Virtualization not enabled"...

I have installed a program called "Securable" which tells if the hardware supports it or not, and it comes up as "No".

Does this sound like an issue to return the CPU back for warranty, or would this desktop CPU really not have "Hardware Virtualization" ability? (All I can read on Intel's site says that it should.)

share|improve this question
    
Is this on host or within the VM? –  Epaphus Apr 4 '13 at 22:23
    
It's on the host; running Windows Server 2012 Standard. –  The Woo Apr 4 '13 at 22:28
    
Did you get a 3770 or a 3770K? –  Grant Apr 4 '13 at 22:40
    
@Grant - the 3770K version also has VT-x according to the Intel website. –  Matt Apr 4 '13 at 22:50
    
It's just the 3770 version, not the K. –  The Woo Apr 4 '13 at 23:11

1 Answer 1

According to this link: Intel® Core™ i7-3770 Processor

It supports Hardware Virtualization VT-x

Most likely the issue is with the BIOS not enabling the Virtualization feature of the CPU even though it says it is enabled. My best guess is that you have and older BIOS revision.

I had a look through the website and full support for the i7-3770 was added in BIOS revision 1801. If your BIOS is older than this then although it may run it might explain why the VT-x feature isn't working. So the first step is to download the latest firmware which is currently 1805. Then see if it works.

share|improve this answer
    
Hmmm! That sounds like it might be it. I checked this morning on the BIOS version and it was the 2nd newest (1708). I shall try to update it tonight and give it a go. Thank you. –  The Woo Apr 4 '13 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.