Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my server I run Plesk 11 (Centos 5 x64), I have many domains. Two of them cannot receive emails. All their emails stay in the queue.

The message I take from the maillog is the following

...relay=plesk_virtual, delay=2457, delays=2457/0.02/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: fork_execv: execv("/usr/sbin/sendmail") failed: Exec format error 4.2.1 Message can not be delivered at this time

Can anyone have an idea how can I fix it?

The /usr/local/psa/admin/sbin/mchk --with-spam, doesn't solve my problem.

Thank you

share|improve this question

1 Answer 1

Exec format error suggests that the executable in question (/usr/sbin/sendmail) is in a foreign format that the system doesn't understand how to execute.

  • Double check the output of uname -a to make sure that this system is in fact running a 64-bit kernel (someone might have botched a kernel upgrade).
  • If the running kernel is in fact 64-bit, try to identify how a binary from a different architecture entirely ended up on your system.
  • Expect to run into this problem again with other binaries until you've identified how this happened.

If you're running a chrooted configuration, remember that the /usr/sbin/sendmail path is relative to the chroot.

share|improve this answer
    
Thank you very much for your answer! I check all of these, but I think is something else.Maybe It's a problem with symlinks(?). I run the following commands : # ll /usr/sbin/sendmail lrwxrwxrwx 1 root root 21 Apr 4 21:30 /usr/sbin/sendmail -> /etc/alternatives/mta ll /etc/alternatives/mta lrwxrwxrwx 1 root root 26 Apr 5 12:05 /etc/alternatives/mta -> /usr/sbin/sendmail.postfix ]# rpm -qf /usr/sbin/postfix postfix-2.8.4-12052415 Are these correct? –  Andrew Apr 5 '13 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.