Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Xen installation has gone weird on me and I am trying to get back to normal.

I overflowed the base partition and in my haste to delete unused files I think I deleted something important, so now the hypervisor won't boot correctly.

I've attempted to uninstall xen-hypervisor-4.0-amd64 and all related packages, and the kernel so that I can replace them. I figured I would upgrade to 4.1 while I was at it, but that's not important.

However, now I'm to the point where after installing I'm not seeing the xen kernel in the grub menu at all, and when I try to uninstall it / re-install it I get a weird file system error, like so:

root@debian:~# dpkg --list 'linux-image*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                  Version                               Description
+++-=====================================-=====================================-==========================================================================================
un  linux-image                           <none>                                (no description available)
un  linux-image-2.6                       <none>                                (no description available)
ii  linux-image-2.6-amd64                 2.6.32+29                             Linux 2.6 for 64-bit PCs (meta-package)
un  linux-image-2.6-openvz-amd64          <none>                                (no description available)
un  linux-image-2.6-vserver-amd64         <none>                                (no description available)
un  linux-image-2.6-xen-amd64             <none>                                (no description available)
ii  linux-image-2.6.32-5-amd64            2.6.32-48squeeze1                     Linux 2.6.32 for 64-bit PCs
rc  linux-image-2.6.32-5-xen-amd64        2.6.32-48squeeze1                     Linux 2.6.32 for 64-bit PCs, Xen dom0 support

Than I run:

root@debian:~# apt-get remove linux-image-2.6.32-5-xen-amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package linux-image-2.6.32-5-xen-amd64 is not installed, so not removed
The following packages were automatically installed and are no longer required:
  python2.5-minimal etherboot iso-codes xen-utils-4.0 python-apt-common python2.5 mknbi lsb-release
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 411 not upgraded.

And finally:

root@debian:~# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-5-amd64
Found initrd image: /boot/initrd.img-2.6.32-5-amd64
Found Debian GNU/Linux (6.0.7) on /dev/mapper/vg0-git--disk
Found Debian GNU/Linux (6.0.6) on /dev/mapper/vg0-postgresql--disk
done

SSH doesn't show it but I get this error in the last command:

[  544.126457] EXT3-fs: write access unavailable, cannot proceed.

I believe this is my problem. However, my fsck at boot, and switching to init1 and un-mounting my file system both report 'clean'?

Thanks for the help!

share|improve this question

1 Answer 1

I'm trying to debug a reboot issue with debian1 2, where I require to pass some kernel options and therefore need to run update-grub. I get the same response as you, and I'm using Xen 4 as well.

When I installed Xen, I used the xen-linux-system and xen-qemu-dm-4.0 packages. Perhaps look at broken dependencies with apt to figure out if you're simply not clearing some of the packages you wish to remove? The filesystem error may be related to this or to something else entirely, perhaps a configuration through LVM or other option as Xen was first installed.

Upon further inspection I realized that my error reads:

[ 1460.508449] EXT4-fs (sdb1): write access unavailable, cannot proceed

However, I'm not mounting sdb1, which explains why it's unavailable. Do you have multiple drives, and perhaps access is unavailable on one of them?

Ultimately, it seems the problem is at os-prober under update-grub and a recommendation3 is to run:

sudo fsck /dev/sdb1 with whatever relevant directory

This seemed to fix the error, or at least stop reporting it. This being a file system issue and requiring fsck to try to repair it seems solid, have you tried fsck yet?

share|improve this answer
    
I am running software raid array...and and LVM ontop of that –  jordan.baucke Apr 10 '13 at 18:57
    
cool, you may not have seen my most recent edit -- have you run fsck? –  Matt Senate Apr 10 '13 at 19:20
    
I did, but it says that /dev/.../ whatever is in use -- I don't have it in front of me –  jordan.baucke Apr 10 '13 at 20:18
    
if it's not your / directory, maybe you can unmount it first? –  Matt Senate Apr 10 '13 at 20:51
    
so running fsck /dev/sda results in /dev/sda is in use, I am booting on md0 (meta-disk, from the software array), so the sda volumes are the actual array disk devices I assume) and thus are unavailable. –  jordan.baucke Apr 11 '13 at 3:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.