Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a dev user who is running queries to bugzilla via .NET code, and after updating his connector gets the error "Authentication with old password no longer supported, use 4.1 style passwords." I tried recreating the same password again for his user with no luck. I have several other users that connect and do not want to impact them. Server version: 5.1.67 Source distribution

I had recently migrated from the old server to a new server, New OS and mysql install. I moved the DBs over using dumps and I added most of the users by using show grants on the old box and copying the output to the new (I am not a mysql guru, obviously).

He is using a username@'%' account if it matters.

CentOS 6.3

share|improve this question
    
I can successfully log in from other remote machines using the same credentials for that user. –  user160910 Apr 5 '13 at 18:06
add comment

1 Answer

up vote 0 down vote accepted

I ended up rehashing the user's password with the newer,longer hash value then issuing a flush-hosts to clear the caches. It worked. I used the first answer Here for reference.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.