Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've taken the following steps:

  1. Created a VPC (with a single public subnet)
  2. Added an EC2 instance to the VPC
  3. Allocated an elastic IP
  4. Associated the elastic IP with the instance
  5. Created a security group and assigned it to the instance
  6. Modified the security rules to allow inbound ICMP echo and TCP on port 22

I've done all this and I still can't ping or ssh into the instance. If I follow the same steps minus the VPC bits I am able to set this up without issue. What step am I missing?

share|improve this question
    
Did you assign a gateway and a route to the VPC subnet? –  zorlem Apr 6 '13 at 4:48
    
If I go to Internet Gateways, there is a gateway assigned to the VPC. How do I check if a route has been assigned? –  Ryan Lynch Apr 6 '13 at 4:52
    
Is route a route table? –  Ryan Lynch Apr 6 '13 at 4:55
    
yes, you need to assign an "internet gateway" to the public routing table. –  zorlem Apr 6 '13 at 4:58
    
Excellent, thanks man. If you put it in the form of an answer I'll accept it. In your answer, could you also specify what exactly to put into the routes table? I put in 0.0.0.0/0 and the target as the internet gateway, but that doesn't sound like the right thing to do. –  Ryan Lynch Apr 6 '13 at 5:07

3 Answers 3

up vote 7 down vote accepted

To communicate outside of the VPC, each non-default subnet needs a routing table and an internet gateway associated to it (the default subnets get an external gateway and a routing table by default).

Depending on the way you have created public subnet in the VPC, you might need to explicitly add them additionally. Your VPC setup sounds like it matches Scenario 1 - a private cloud (VPC) with a single public subnet, and an Internet gateway to enable communication over the Internet from the AWS VPC documentation.

You will need to add an internet gateway to your VPC and inside the Public subnet's routing table assign 0.0.0.0/0 (default route) to go to the assigned internet gateway. There is a nice illustration of the exact network topology inside the documentation.

Also, for more information, you can check the VPC Internet Gateway AWS documentation. Unfortunately it's a little messy and a non-obvious gotcha.

share|improve this answer
    
In addition to assigning the default route for the internet gateway I also had to associate the subnet with the routing table. But once I had done these two things I was up and running. Thanks. –  Sam Kenny Oct 17 '13 at 15:41

You should allocate an ENI and assign the Elastic IP to this ENI. Also, you should assign this ENI to your VPC. The route table must be correct too, to correctly forward the outside packets to your VPC.

share|improve this answer
    
I believe that adding an ENI is needed when you want additional network interfaces on your instances, by default they come with one NIC. –  zorlem Apr 6 '13 at 5:57

I've noticed that (I think) you need to be careful about which availability zone your instance is created in. The SubNet, Network Interface and Instance need to be in the same availability zone otherwise there is no way to connect to a public IP for that instance.

I may be wrong - but I don't think so, this has cost me 12 hours of work to figure out.

Hope this helps someone else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.