Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an issue with a new mdadm raid.

When i try to:

root@dys:~# mdadm --add --verbose /dev/md0 /dev/sdb1
mdadm: Cannot open /dev/sdb1: Device or resource busy

dmraid i pointed as the usual problem but it's not even installed.

Also tried to check it with lsof and no result.

Im just out of ideeas

the output of /proc/mdstat if of any help:

root@dys:~# cat /proc/mdstat
Personalities : [raid1]
md1 : active (auto-read-only) raid1 sdb2[2] sda2[1]
      7858164 blocks super 1.2 [2/2] [UU]

md0 : active (auto-read-only) raid1 sda1[1]
      968900472 blocks super 1.2 [2/1] [_U]

unused devices: <none>
share|improve this question
    
Are you sure /dev/sdb1 is not mounted? –  etagenklo Apr 6 '13 at 16:21
    
mount | grep sdb1 doesn't show anything, and /dev/md0 on / type ext4 (rw,errors=remount-ro). Any other way to check ? –  Debrian Apr 6 '13 at 16:28

1 Answer 1

up vote 0 down vote accepted

What about this way: mdadm /dev/md0 -a /dev/sdb1 ?

What is the output of lsblk /dev/sdb1?

share|improve this answer
    
Same result: mdadm /dev/md0 -a /dev/sdb1 mdadm: Cannot open /dev/sdb1: Device or resource busy –  Debrian Apr 6 '13 at 18:05
    
@Adrian, ok, let's go further — see update –  poige Apr 7 '13 at 2:27
1  
Ok that helped a lot. First of all lsblk is not present in debian stable, so i had to get it from testing and discovered that /dev/sdb1 was mounted on /, although mount and umount where saying it's not. I redo the grub configuration (the first time i miss-copied a uuid it seems) and now everything works according to plan. Lesson learned lsblk is a nice tool. –  Debrian Apr 7 '13 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.