Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
Specific Error: Agent proxying needs to be enabled for a health service to submit discovery data about other computers.

Microsoft.SystemCenter.DiscoveryWriteActionModule.AgentProxyingNotEnabled.Alert

We use Microsoft System Center 2007. The management server throws this error. I have enabled proxying per the instructions but alas the error re-occurs. Has anyone else had this and fixed it? or do I just disable the monitor?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
+100

Following that alert you should get a specific ID for the managed object. Run this query in SQL server against the OperationsManager database:

select * from basemanagedentity where basemanagedentityid = 'IDGOESHERE'

and then check the Path column. It will list one of your servers. Make sure Agent Proxying is enabled for that specific health service/server.

  1. In the SCE console, click 'Administration'.

  2. Click 'Agent Managed'

  3. Double-click the above listed server. (Or right-click and select properties.)

  4. In security tab, choose "Allow this agent to act as a proxy and discover managed objects on other computers"

share|improve this answer
    
I had performed the above, however in the DB it did not exist...I flipped the bit manualy and all is good now. Thanks for the lead! –  Thomas Denton May 14 '09 at 17:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.