Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up Apache 2.4 on 64-bit Windows Server 2008 R2. I downloaded the 32-bit zip from Apache Lounge and unzipped, also installed VC10 SP1.

Then, when I tried to run httpd.exe, I got an error:
The application failed to initialize properly(0xc000007b)

The same thing worked on my 64-bit Win7.

Any insights?


EDIT

Ran Depency Walker on httpd.exe. Missing dependencies are:

  • IESHIMS.DLL
  • MF.DLL
  • MFPLAT.DLL
  • MFREADWRITE.DLL
  • WLANAPI.DLL

IESHIMS.DLL: This is also missing in my Win7 httpd. Don't think is the problem.
WLANAPI.DLL: Go to Control Panel > Administrative Tools > Server Manager > Features (left panel) > Add Feature > check Wireless LAN Services to enable it. After that, wlanapi.dll is in the system32 folder.
The rest: These are related to "Media Foundation", but I don't know how to install/enable.
(edit: Some say installing "Desktop Experience" will include Media Foundation, will test)


EDIT2

Apache 2.2 from apache.org is also missing those dlls but runs perfectly fine on the server!!

So, it's not a dependency problem...

share|improve this question
add comment

2 Answers 2

Though you are not building your own application, the error (and solution) still apply.

Stack Overflow - The application was unable to start correctly (0xc000007b)

Edit:

Additionally, you can try running the following commands

chkdsk X: /R

sfc /scannow

share|improve this answer
    
So I run Dependency Walker on both the WinServer08 and Win7, the server is missing quite a few dll, including mf.dll, mfplat.dll, wlanpi.dll, etc. Is it good to transfer those from my Win7 to the server? If not, how can I fix this? –  TwiNight Apr 7 '13 at 20:24
    
Added some more info - sfc /scannow is likely to be the one that fixes things up. –  Sašo Apr 7 '13 at 20:37
    
sfc /scannow: "Windows Resource Protection didn't find any integrity violations". Then I transfered the Win7 dlls into the server and then sfc /scanfile=...: "Windows Resource Protection cannot perform the requested operation". Ran chkdsk still no luck. –  TwiNight Apr 8 '13 at 1:10
add comment
up vote 0 down vote accepted

Alright, found a workaround.

Downloaded the VC9 version instead of the VC10 one and it runs without problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.