Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I ma trying setup MariaDB in cluster but looks like I stuck on this error:

#mysqld -u mysql
130407 21:36:24 InnoDB: The InnoDB memory heap is disabled
130407 21:36:24 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130407 21:36:24 InnoDB: Compressed tables use zlib 1.2.7
130407 21:36:25 InnoDB: Initializing buffer pool, size = 2.0G
130407 21:36:26 InnoDB: Completed initialization of buffer pool
130407 21:36:27 InnoDB: highest supported file format is Barracuda.
130407 21:36:29  InnoDB: Waiting for the background threads to start
130407 21:36:30 Percona XtraDB (http://www.percona.com) 5.5.30-MariaDB-30.1 started; log      sequence number 757767234118
130407 21:36:30 [ERROR] mysqld: unknown variable 'wsrep_provider=/usr/lib/libgalera_smm.so'
130407 21:36:30 [ERROR] Aborting

130407 21:36:30  InnoDB: Starting shutdown...
130407 21:36:31  InnoDB: Shutdown completed; log sequence number 757767234118
130407 21:36:31 [Note] mysqld: Shutdown complete 

Anyway whatever setting I put in my.cfg first with wsrep I am getting this error ANy idea what is wrong?

this is my config:

[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock
[mysqld]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock
skip-external-locking
key_buffer_size = 16M
max_allowed_packet = 1M
table_open_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
default_storage_engine  = InnoDB
log-bin=mysql-bin
binlog_format=ROW
server-id       = 510
sync_binlog=1
default-time-zone='US/Eastern'
log-slave-updates = 1
wsrep_provider = /usr/lib/libgalera_smm.so
wsrep_cluster_address = gcomm://
wsrep_retry_autocommit = 0
wsrep_sst_method = rsync
wsrep_sst_auth=sst:sstpasswd
innodb_file_per_table
innodb_open_files = 2048
innodb_data_home_dir = /var/lib/mysql
innodb_data_file_path = ibdata1:2000M;ibdata2:2000M;ibdata3:100M:autoextend
innodb_log_group_home_dir = /var/lib/mysql/mysql_logs/
innodb_buffer_pool_size = 2048M
innodb_additional_mem_pool_size = 512M
innodb_log_file_size = 1536M
innodb_log_buffer_size = 50M
innodb_flush_log_at_trx_commit = 0
innodb_lock_wait_timeout = 50
innodb_flush_method = O_DIRECT
innodb_write_io_threads = 32
innodb_read_io_threads = 32
innodb_thread_concurrency = 16
innodb_support_xa = false
innodb_autoinc_lock_mode=2
innodb_doublewrite=0

So what step with this setup I am missing. OS Arch Linux

#pacman -Q | grep galera
galera 23.2.2-2
#whereis libgalera_smm.so
libgalera_smm: /lib/libgalera_smm.so /usr/lib/libgalera_smm.so /lib64/libgalera_smm.so /usr/lib64/libgalera_smm.so

#mysqld -u mysql
130407 22:12:20 InnoDB: The InnoDB memory heap is disabled
130407 22:12:20 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130407 22:12:20 InnoDB: Compressed tables use zlib 1.2.7
130407 22:12:20 InnoDB: Initializing buffer pool, size = 2.0G
130407 22:12:20 InnoDB: Completed initialization of buffer pool
130407 22:12:20 InnoDB: highest supported file format is Barracuda.
130407 22:12:20  InnoDB: Waiting for the background threads to start
130407 22:12:21 Percona XtraDB (http://www.percona.com) 5.5.30-MariaDB-30.1 started; log    sequence number 761369976882
130407 22:12:21 [ERROR] mysqld: unknown variable 'wsrep_provider=/usr/lib/libgalera_smm.so'
130407 22:12:21 [ERROR] Aborting

130407 22:12:21  InnoDB: Starting shutdown...
130407 22:12:22  InnoDB: Shutdown completed; log sequence number 761369976882
130407 22:12:22 [Note] mysqld: Shutdown complete

??? And Thx for help

share|improve this question

3 Answers 3

There's an error in your config, some of the options (like the wsrep_* ones) have to be in the [mysqld_safe] section, not in the [mysqld] section.

That's what your error is about:

mysqld: unknown variable 'wsrep_provider=/usr/lib/libgalera_smm.so'

"mysqld" does not know the variable "wsrep_provider", but "mysqld_safe" does know it.

share|improve this answer

I see you have the line that the error output is telling you, but if this is on a 64bit system, you'll have to find the appropriate place for it. If you use the find command:

find / -name '*galera*'

You should see something that would resemble the libgalera_smm.so somewhere. Mine was under /usr/lib64/libgalera_smm.so.

share|improve this answer
up vote 0 down vote accepted

I solve the problem, there was some bug with gcc version 4.7.2 (GCC) when i did downgrade to 4.2 all works fine, also if i use the generic package for galera all works too

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.