Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I cant seem to get the SYSVOL folder to replicate. Once joined my Event Log spits out the following.

The DFS Replication service initialized SYSVOL at local path C:\Windows\SYSVOL\domain and is waiting to perform initial replication. The replicated folder will remain in the initial synchronization state until it has replicated with its partner NTE-AUTHSRV.NASUTEK-CORE.nisn.nasutek.com. If the server was in the process of being promoted to a domain controller, the domain controller will not advertize and function as a domain controller until this issue is resolved. This can occur if the specified partner is also in the initial synchronization state, or if sharing violations are encountered on this server or the synchronization partner. If this event occurred during the migration of SYSVOL from File Replication service (FRS) to DFS Replication, changes will not replicate out until this issue is resolved. This can cause the SYSVOL folder on this server to become out of sync with other domain controllers. 

Additional Information: 
Replicated Folder Name: SYSVOL Share 
Replicated Folder ID: 9149BE82-BD4D-42D9-8E6C-C900D799E3E4 
Replication Group Name: Domain System Volume 
Replication Group ID: A9B325AD-85F2-4B0B-BF83-404FF8172FB8 
Member ID: B61BF26F-A357-431F-8AF2-90DB0A844851 
Read-Only: 0

The DFS Replication service failed to update configuration in Active Directory Domain Services. The service will retry this operation periodically. 

Additional Information: 
Object Category: msDFSR-LocalSettings 
Object DN: CN=DFSR-LocalSettings,CN=administrator2,OU=Domain Controllers,DC=NASUTEK-CORE,DC=nisn,DC=nasutek,DC=com 
Error: 2 (The system cannot find the file specified.) 
Domain Controller: NTE-AUTHSRV.NASUTEK-CORE.nisn.nasutek.com 
Polling Cycle: 60

The DFS Replication service has detected that no connections are configured for replication group Domain System Volume. No data is being replicated for this replication group. 

Additional Information: 
Replication Group ID: A9B325AD-85F2-4B0B-BF83-404FF8172FB8 
Member ID: B61BF26F-A357-431F-8AF2-90DB0A844851

I tried everything I can possibly think of but this one just stumps me.

EDIT: I added some additional information at https://gist.github.com/michael-manley/5343111 for any other commands I executed.

share|improve this question
    
The DFS Replication service has detected that no connections are configured for replication group Domain System Volume. No data is being replicated for this replication group. Well, did you configure a connection for your new domain controller? Seems that it's not generating one automatically. –  HopelessN00b Apr 9 '13 at 3:34
    
How would i go about doing that? I thought the SYSVOL is automatic and no manual configurations can be done. –  DrHouse Apr 9 '13 at 3:38
    
Sounds like you're in way over your head, no offense. The MMC snap-in you use to configure this type of thing is Active Directory Sites and Services. In order to replicate between each other, Domain Controllers must have a connection configured between them. If they're not generated automatically (because of a lack of inter-site links, usually), you need to create the proper inter-site links and wait for KCC to generate the connections automatically, or set them manually. –  HopelessN00b Apr 9 '13 at 3:56
    
It seems the inner sites are all correct, I see both servers in Default-First-Site-Name. Everything other then DFSR is working right (AD, DNS). I'm just trying to migrate from one server to another, and i done this countless times without issue, just not on 2012 to 2012. I should also mention in the DFS Replication MMC Console, it shows both DC's in the Replication, just its not actually replicating. –  DrHouse Apr 9 '13 at 4:27
    
Seeing the servers isn't enough to confirm that replication connections actually exist. Do you see replication connections in the NTDS settings for each server? Each DC should have a replication connection from the other DC. –  joeqwerty Apr 9 '13 at 4:33

1 Answer 1

up vote 2 down vote accepted

I Finally Figured out the issue was on the PDC. I found this log entry in the DFSR Logs

The DFS Replication service stopped replication on volume C:. This occurs when a DFSR JET database is not shut down cleanly and Auto Recovery is disabled. To resolve this issue, back up the files in the affected replicated folders, and then use the ResumeReplication WMI method to resume replication. 

Additional Information: 
Volume: C: 
GUID: 89131A39-4A90-11E2-93EB-806E6F6E6963 

Recovery Steps 
1. Back up the files in all replicated folders on the volume. Failure to do so may result in data loss due to unexpected conflict resolution during the recovery of the replicated folders. 
2. To resume the replication for this volume, use the WMI method ResumeReplication of the DfsrVolumeConfig class. For example, from an elevated command prompt, type the following command: 
wmic /namespace:\\root\microsoftdfs path dfsrVolumeConfig where volumeGuid="89131A39-4A90-11E2-93EB-806E6F6E6963" call ResumeReplication 

For more information, see http://support.microsoft.com/kb/2663685.

I ran the command, restarted DFSR, and replication finally kicked in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.