Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Well I have an issue when I want to run SVN, I already explorer all the related question but I couldn't get what is wrong in my case. So that's why I decided to post my question in here, kindly help me to double check all the steps.

I am using Apache version 2.0 and my SVN version is 1.4.

I am receiving :"Forbidden You don't have permission to access /svn/ on this server." when I enter

 http://localhost/svn/

in my computer.

Forbidden You don't have permission to access /svn/ on this server.


Apache/2.0.64 (Win32) SVN/1.4.0 DAV/2 Server at localhost Port 80

I already setup my apache and SVN server based on here but I dont know what is wrong with my setup that I am receiving permission deny error message. I am wondering help me and double check my work to identify the root cause of problem.

my httpd.conf:

<Location /svn/>
    DAV svn
    SVNParentPath c:/svnroot/ 
    SVNListParentPath on
    AuthzSVNAccessFile bin/apachesvnauth 

    AuthType Basic 
    AuthName "Subversion repository" 
    AuthUserFile bin/apachesvnpasswd 

    Require valid-user                                 </Location>

my authentication file.

[/]
* = r 

[test1:/] 
user1 = rw 
user2 

[test2:/] 
user1 = r 
user2 = rw

If you need any more information keep me posted so I can share with you. I am using windows xp. one more thing I already assign all the read and write privilege for SVN and repository folder to my own user as well.

my apache log is as below:

> [Wed Apr 10 15:49:34 2013] [notice] Server built: Oct 18 2010 01:36:23
> [Wed Apr 10 15:49:34 2013] [notice] Parent: Created child process 1656
> [Wed Apr 10 15:49:35 2013] [notice] Child 1656: Child process is
> running [Wed Apr 10 15:49:35 2013] [notice] Child 1656: Acquired the
> start mutex. [Wed Apr 10 15:49:35 2013] [notice] Child 1656: Starting
> 250 worker threads. [Wed Apr 10 15:49:48 2013] [error] [client
> 10.8.8.139] Access denied: 'user1' GET svn:/
share|improve this question
    
"Apache version 2.0 and my SVN version is 1.4"? Why SVN 1.4? It's too outdated. –  bahrep Apr 10 '13 at 11:33
    
which version you recommend that apache and SVN working properly in both? –  rima Apr 10 '13 at 12:32
    
Decide about Apache HTTP Server version yourself, but SVN should not be 1.4. 1.4 is too outdated. The latest version is 1.7.9: subversion.apache.org/docs/release-notes –  bahrep Apr 11 '13 at 14:13

2 Answers 2

Within your <Location /svn/> block, add Order allow,deny and Allow from all.

share|improve this answer
    
Do u mean like below? <Location /svn/> DAV svn SVNParentPath c:/svnroot/ SVNListParentPath on AuthzSVNAccessFile bin/apachesvnauth AuthType Basic AuthName "Subversion repository" AuthUserFile bin/apachesvnpasswd Require valid-user Order allow,deny Allow from all </Location> If your answer is yes, it still isnot working –  rima Apr 10 '13 at 6:52
    
I tried below aswell, still same problem: <Directory "C:/SVN"> Order allow,deny Allow from all </Directory> <Directory "C:/svnroot"> Order allow,deny Allow from all </Directory> –  rima Apr 10 '13 at 6:59
    
@rima Please provide the output from the Apache error log when one of those requests is made. –  Shane Madden Apr 10 '13 at 19:01
    
check my edit. in last part I added my log –  rima Apr 11 '13 at 6:49
    
@rima Looks like the block is occurring from the svn access file - does it work when you disable it, and/or when you directly access http://localhost/svn/test1 instead of http://localhost/svn/? –  Shane Madden Apr 12 '13 at 3:31
  1. If your server is Windows-host (as I see from SVNParentPath string), write full path (not relative) to AuthzSVNAccessFile|AuthUserFile
  2. You can test anonymous access to repository by adding (temporary) Satisfy any into Location container
  3. If you want to have explicit access-rules in config (while missing means Allow from all AFAICR), and string to Location container also, not Directory
  4. Test configuration by accessing

    • Repository, not repositories root
    • by SVN-client, not browser (you'll see all possible trobles in one shot)

5.Fix user2 in test1 repo, use correct format of line

share|improve this answer
    
I tried but non of above solution helped. I didnt understand the step 4 would you explain more? if you mean I try to connect localhost/svn/ from GUI, I tried but it couldnt fetch any xml! –  rima Apr 11 '13 at 6:48
1  
@rima - point 4 is "Use svn ls http:localhost/test2/ (when repo in test2 exist) - it produce more readable error, that browser" –  Lazy Badger Apr 11 '13 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.