Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to redirect https requests to http on an apache server.

I have updated my .htaccess file as described in this previous question:

Redirect HTTPS to HTTP

However, this doesn't work and gives (in Chrome):

Error 102 (net::ERR_CONNECTION_REFUSED): The server refused the connection.

I am guessing that the server isn't enabled to handle 443 requests. So my question is - is there a graceful way to handle this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

If your server is not listening on port 443 there is no way you can have it do anything on requests send to that port. If you want your server to redirect from https to http you will first have to enable https on that server.

share|improve this answer
    
As I suspected. So I have enabled SSL on apache but now when you go to the https address before it redirects to http you get the untrusted certificate message as it is now using a self signed certificate. Is there a way to redirect without this. I am guessing not. –  williamsdb Apr 11 '13 at 9:02
    
go to startssl.com and issue one year free certificate there. –  Marcel Apr 11 '13 at 16:12
    
So just to close this off I got a free certificate from startssl and then installed following these instructions: jasoncodes.com/posts/startssl-free-ssl now redirects fine. Thanks –  williamsdb Apr 12 '13 at 10:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.