Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working with two servers in two different datacenters, hosting providers and not on any corporate network.

I'd like to be able to connect the two of them through a VPN. I use RDP. When I connect the client to the server (hosting the VPN) the RDP session dies.

What setting do I need to change in order to have a VPN connection from one machine connected to via RDP to another hosting the VPN connection as hosting the VPN server process?

share|improve this question
    
Do you have any options on the VPN? Are the servers NAT'd or are the IPs accessible publicly? I would say a good solution would be to set up a static L2TP IPSEC tunnel between them, that way you don't have to worry about it crashing when the network stack changes –  Snowburnt Apr 11 '13 at 19:20
    
Thanks for the tip. :) –  arachnode.net Apr 13 '13 at 1:57
add comment

2 Answers

up vote 1 down vote accepted

For RDP you simply need the server (machine you are connecting to) to be listening for RDP connections (have the service turned on) the user account needs to be a member of remote desktop users group or higher (admins are in this group by default) and you will need TCP/UDP access on port 3389, or have port forwarding enabled to take RDP traffic on another port and then forward it to 3389 on the internal interface of your router.

share|improve this answer
add comment

Assuming you are using Microsoft PPTP VPN to connect one machine to the other then the setting you need to change in the client side (server doing the connecting) is the "Use default gateway on remote network" setting. When that box is ticked and the VPN tunnel is connected all of that servers internet access is done through the other servers connection. That is why you suddenly lose connection because the client is not longer getting to the internet via the IP you connected to.

To fix this option: 1.) Go to Properties on the VPN connection on the client side. 2.) Go to Networking tab and do a properties on TCP/IP v4. 3.) Go to Advanced. 4.) Uncheck "Use default gateway on remote network".

Pulled that from memory but it should be mostly accurate. ;-)

If you're not using MS PPTP VPN then I've no idea... it may depend on your VPN solution.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.