Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

For a long time I have been trying to get postfix to work on my server, I gave up a while back but now I have no choice but to get it working.

after configuring the main.cf file and restarting postfix there seems to be a number of errors which I have no idea how to fix even after googling for solutions.

Errors

/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_client_restriction=permit_mynetworks,reject_unknown_client,permit
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: body_check=regexp:/etc/postfix/body_checks
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smptd_sasl_type=dovecot
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smptd_sasl_path=private/auth

main.cf

command_directory = /usr/sbin

daemon_directory = /usr/lib/postfix

data_directory = /var/lib/postfix
mail_owner = postfix

myhostname = mail.xxxxxxbooks.com

mydomain = xxxxxxbooks.com

myorigin = $mydomain

inet_interfaces = all

mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain

local_recipient_maps = unix:passwd.byname $alias_maps

unknown_local_recipient_reject_code = 550

mynetworks = 127.0.0.0/8, 78.129.200.10

alias_maps = hash:/etc/aliases

alias_database = hash:/etc/aliases

home_mailbox = Maildir/

header_checks = regexp:/etc/postfix/header_checks

body_check = regexp:/etc/postfix/body_checks

smtpd_banner = $myhostname ESMTP

debugger_command =
     PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
     ddd $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/postfix

newaliases_path = /usr/bin/newaliases

mailq_path =  /usr/bin/mailq

setgid_group = postdrop

message_size_limit = 10485760


smptd_sasl_type = dovecot
smptd_sasl_path = private/auth
smtpd_sasl_auth_enable = yes

smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname

smtpd_client_restriction = permit_mynetworks,reject_unknown_client,permit 
#smtpd_recipient_restrictions = permit_mynetworks,permit_auth_destination,permit_sasl_authenticated,reject 
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

Edit

I have an Ubuntu 12.04.1 server which runs apache.

If anyone could help I would really appreciate it.

share|improve this question
    
What OS, version and postfix version are you using? –  NickW Apr 12 '13 at 14:19
    
Sorry I forgot the add that in, i'll edit the question –  mk_89 Apr 12 '13 at 14:21
    
@NickW Ubuntu 12.04.1 –  mk_89 Apr 12 '13 at 14:22

2 Answers 2

up vote 2 down vote accepted

You've misspelled the parameters.

It's smtpd_client_restrictions <-- note the s

body_checks

smtpd_sasl_path not smptd

the same thing for smtpd_sasl_type

share|improve this answer
    
OK, the only warning I have left is postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_client_restriction=permit_mynetworks,reject_unknown_client,permit Should I remove this line? –  mk_89 Apr 12 '13 at 14:40
    
no, add an s to the end of restriction.. after all it's not just one restriction, it's multiple :) –  NickW Apr 12 '13 at 14:47
    
I get you now, thanks, on to the next problem. –  mk_89 Apr 12 '13 at 14:50
    
You're welcome, best of luck! –  NickW Apr 12 '13 at 14:54

These are only warnings so you do not need to worry much. If you care though, you can delete or comment out these directives from main.cf or start to use them by reconfiguring your postfix in the way they get some meaning.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.