Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server with an ASUS board with a 256GB SSD

In Windows, using HDTune my drive shows 400MB/sec

on Linux, I'm getting about 2MB/sec using

root@desktop:/# dd if=/dev/zero of=/foo bs=1024k count=100
100+0 records in
100+0 records out
104857600 bytes (105 MB) copied, 89.3776 s, 1.2 MB/s

any ideas what could be going wrong? the boss man is not happy and I am stumped :)

one clue may be that the 'Disks' utility on Ubuntu, using the Benchmark feature, gives the error "Error seeking to offset ... (g-io-error-quark, 13)

share|improve this question

closed as off topic by mdpc, Dennis Kaarsemaker, Dave M, Ward, Jenny D Apr 13 '13 at 11:28

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try a larger BS, like 1m. Also, testing 64 MB of data is way too little to get a reasonable assessment of IO speed. You need to test at least 2x your RAM size to start eliminating cache influences. What driver is the SATA controller using? –  Chris S Apr 12 '13 at 16:49
    
Can you please post the actual output? Also, my first guess is some sort of horribly misconfigured driver, or lack of TRIM usage on the Linux side. –  Jeff Ferland Apr 12 '13 at 16:50
    
[post updated with bigger block size, dd output, and a clue with the Disks utility in Ubuntu] –  stuck Apr 12 '13 at 17:08
    
I like the idea of driver misconfiguration - any tips there? I enabled TRIM (discard) and that didnt seem to help –  stuck Apr 12 '13 at 17:34

1 Answer 1

thanks everyone for the tips - I have a solution!

the problem was I had x86 versions of Ubuntu installed - when I installed x64 the performance went to 560MB/sec measured from the 'Disks' application (which was failing on x86)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.