Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using client - server software called XSockets. I can run it on my local computer, but I cannot on my web server. This is my home configuration (win7 IIS7):

myDomainName.com points directly at 111.111.111.111(lets say my home IP ;)). Now 111.111.111.111 is my local router, that DMZ's everything to my local computer, which is 192.168.0.10.

Now, when I setup my local XSockets server to listen on 192.168.0.10 (I doesn't fully understand why I need to explicitly specify that, but let's omit that, the question is not about that) everything works as intended, and by that I mean, that I can go to https://myDomainName.com and everything works fine.

Important note: as you can see above, I am accessing my page from within https:// protocol - that is required for my configuration, it cannot be plain http:// (I am pointing this out because maybe this has something to do with my problem).

Now here is the problem: I am setting up the same configuration on my web server (win2008 R2 IIS7.5), the only difference is, that my server has myServerDomain.com with ip 222.222.222.222 pointing directly at the server (no nat here, no LAN ip), so I am setting XSockets to listen at 222.222.222.222. This does not work for me at all.

Questions:

  1. Obviously - why it is not working? Am I maybe missing some IP configuration at my server?
  2. How can I debug this out?
  3. What is the difference between having a LAN IP and having a public IP? I mean of course, in my case, because my point of view is, that since 192.168.0.10 points to my local PC, then the server is working fine, since it is running on that PC. So, as for me, it is logical, that if there is no LAN, then 222.222.222.222 should work as my PC address, so the app should work too. Right?

Edit: Of course firewall is not the case - I was testing everything with firewall turned off completely.

Edit2: I was reading my post and I thought that I need to share some more info about that - First of all, XSockets is a WebSocket framework, I have almost successfuly integrated it with my website (that runs on 222.222.222.222). As I mentioned above, I need to use https, that's because XSockets are working on plain ws:// protocol without a problem (with 222.222.222.222 in setup). The problem begins, when I try to use wss:// with 222.222.222.222. https:// on my server works fine (and to be clear - https:// with wss:// are working fine also on my local pc - 192.168.0.10). So every configuration is working but wss:// on my server.

share|improve this question
    
Just to make sure, on your win2008 machine, if you open a command prompt and type in ipconfig and press enter, the IP that is displayed is 222.222.222.222, right? –  Snowburnt Apr 12 '13 at 19:46
    
@Snowburnt: Yes. –  ojek Apr 12 '13 at 19:47
1  
My only thought would be to check the windows firewall and make sure it's allowing traffic through port 443 or for xsockets, or it's disabled. Also check any upstream firewalls to make sure 443 is allowed. –  Snowburnt Apr 12 '13 at 19:49
    
@Snowburnt: Yeah, already checked that. Not making any difference. :/ Anyways thanks for input. :) –  ojek Apr 12 '13 at 19:52

1 Answer 1

I looked on the vendors website. http://www.xsockets.net/api/hosting Are you hosting within your own windows service? I found on their workarounds page on regarding using certificates.

http://www.xsockets.net/api/known-issues-work-arounds

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.