Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

ELB is setup to accept public HTTPS (443) connections and send them on as HTTP (80) to the EC2 instances.

The EC2 instances run an IIS app that needs to know the user's IP address. According to everything I've read on this site and elsewhere, ELB is supposed to stash that information in a header named "X-Forwarded-For". For whatever reason, ELB doesn't seem to be passing that particular header to IIS (or IIS is stripping it out?).

Any idea what I could be doing wrong?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like you're using Layer 4 instead of layer 7. Change the front-end protocol (called 'load balancer protocol' in the console settings) from SSL(Secure TCP) to HTTPS (Secure HTTP).

share|improve this answer
    
Sure enough, that did it. Thanks. I wouldn't have thought to look there. –  Chad Decker Apr 13 '13 at 20:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.