Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a gigabit connection that is not fully utilized but I am getting packet receiving loss.

When I do netstat, it shows the Recv-Q sometimes maxes out at 262656 during heavy traffic.

Proto Recv-Q
udp   262656

I've tried increasing these settings and rebooting my application but it doesn't seem to do anything.

sudo sysctl -w net.core.rmem_default=4194304
sudo sysctl -w net.core.wmem_default=4194304
sudo sysctl -w net.core.rmem_max=16777216
sudo sysctl -w net.core.wmem_max=16777216

How do I increase the Recv-Q?

share|improve this question

Since Kernel 2.6.25 you have:


man 7 udp has details

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.