Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed Alfresco Community 4.2.0c (manual install) with these Tomcat settings in

CATALINA_OPTS="-Xms512m -Xmx1024m -Xss1024k -XX:MaxPermSize=900m -XX:NewSize=512m -server -Dalfresco.home=/home/aegif/alfresco"

On Oracle jdk1.7.0_15, Linux 2.6.18, CentOS 5.8.
When I launch, Alfresco starts running, but a minute after the Alfresco started message, I get:

Apr 15, 2013 7:17:32 PM org.apache.catalina.startup.HostConfig deployWARs
SEVERE: Error waiting for multi-thread deployment of WAR files to complete
java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: PermGen space

How can I get this error even though MaxPermSize=900m which is already a huge value?
By the way, I get the same exception with other MaxPermSize values like 256m or 700m.

Hint: The log says:

maximum heap size 247.500MB
WARNING - maximum heap size 247.500MB is less than recommended 512MB

Even though has -Xmx1024m.

Is my CATALINA_OPTS wrong?

share|improve this question
Would the NewSize option be the one it's complaining about? – NickW Apr 15 '13 at 10:52
@NickW: Same error message and same numbers with NewSize=512m – Nicolas Raoul Apr 15 '13 at 10:54
Do you have a JAVA_OPTS option, or a file somewhere? – NickW Apr 15 '13 at 10:58

1 Answer 1

up vote 2 down vote accepted

It appears that its taking the CATALINA_OPTS value from somewhere else, have a look at also try to put/define these settings in instead of

share|improve this answer
Moving the settings from to worked! (always at the beginning of the file, after the first line, by the way) – Nicolas Raoul Apr 16 '13 at 3:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.