Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are having an issue with our setup that I think is tied to our cisco 2960's

Below is our network setup on a simple level

http://www.gliffy.com/pubdoc/4481292/L.png

Now our switch config for the WAN/Internal/VLAN groups look like

Rapid pvst is enabled

spanning-tree mode rapid-pvst

Here are the port-channels

interface Port-channel1
 description WAN LAG Group
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
!
interface Port-channel2
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
!
interface Port-channel3
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
!
interface Port-channel4
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
!
interface Port-channel5
 switchport mode trunk
 spanning-tree portfast trunk
!
interface Port-channel6
 switchport mode trunk
 spanning-tree portfast trunk
!

Here are te interfaces for them

interface GigabitEthernet1/0/1
 switchport access vlan 100
 switchport mode access
 duplex full
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/3
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/4
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/5
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/21
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 5 mode active
!
interface GigabitEthernet1/0/22
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/23
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 4 mode active
!

interface GigabitEthernet2/0/1
 switchport access vlan 100
 switchport mode access
 duplex full
 spanning-tree portfast trunk
!
interface GigabitEthernet2/0/3
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 4 mode active
!
interface GigabitEthernet2/0/4
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 2 mode active
!
interface GigabitEthernet2/0/5
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 1 mode active
!

interface GigabitEthernet2/0/21
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 6 mode active
!
interface GigabitEthernet2/0/22
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 5 mode active
!
interface GigabitEthernet2/0/23
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 3 mode active
!

So

  • ports 21/22 on both switches are for my VLAN networks
  • ports 4/5 are for the WAN ip
  • ports 3/23 are for the internal subnet
  • ports 1 are my uplink drops.

Now the primary drop for HSRP is plugged into switch1 and when I reboot switch1 it's around a 2 minute downtime. I've confirmed with our uplink that our default gw is being set on their end ok. I can ping that just fine

so i have no idea whats up

share|improve this question
    
Hi Mike, long time no see. The title of your post indicates that you think that the issue is with HSRP. Can you describe how this is setup with your provider? Your diagram shows the uplinks to the provider cloud converging -- do you have one link or two from them? Are they running HSRP or are you? How are you testing "downtime" after rebooting switch 1? Does switch 2's console show that is has taken over as the stack master? –  Keller G Apr 16 '13 at 19:59
    
Ya what you did got me to where i can reboot astaro's and the secondary line switch. HSRP primary is going into switch1 and only if i reboot switch1 I get 2 minutes of downtime. If I'm plugged into the switch I'm able to ping anything in our lan. My uplink is running HSRP –  Mike Apr 16 '13 at 20:22
    
So, your provider is running HSRP. Based on your diagram, I'm not sure how that's configured. If you reboot switch 1, are you able to ping your provider IP immediately by being plugged into switch 2? Normally HSRP provides redundancy from the HSRP-enabled devices going down, not downstream devices like yours. I guess I'm missing what HSRP is doing in your situation. What is your physical topology between your switches and the provider? Can you post the full configs for your switch stack (pastebin)? –  Keller G Apr 16 '13 at 20:59
    
here's the config pastebin.com/NS2Ft6pz Right now if we reboot switch1 which goes to the primary hsrp link.. we can't ping anything internal or the uplink till both switches come online –  Mike Apr 17 '13 at 16:32
    
serverfault.com/questions/498203/… ?? –  cpt_fink Apr 18 '13 at 4:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.