Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Specifically the process called dbsrv10 is always pegged at 100% or more CPU usage.

I've tried clearing the queue-flush using these commands: zman queue-flush F zman queue-flush S

However this only settled the CPU for about 20 minutes.

I'm running ZCM 10.2.0 on SLES10 SP2 on VMWare 3.5.

I recently disabled Patch Management completely because it was causing disk space issues.

My loader-messages.log file is always very busy, maybe someone can make sense of this:

[DEBUG] [8/4/09 9:29:19 AM] [] [Loader.Status Storer Module] [] [failed directory size:1763657] [] [] [DEBUG] [8/4/09 9:29:19 AM] [] [Loader.Status Storer Module] [] [Moved Status_b11714bce362d4ea7e377f550b19e8aa_1249396137 593.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Processing Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396185 656.xml] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [failed directory size:1766252] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Moved Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396185 656.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Processing Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396185 546.xml] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [failed directory size:1766856] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Moved Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396185 546.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Processing Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396188 625.xml] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [failed directory size:1767460] [] [] [DEBUG] [8/4/09 9:29:49 AM] [] [Loader.Status Storer Module] [] [Moved Status_f8bbe0db5ba4f3a5d3d5e97b3ca01f52_1249396188 625.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:30:19 AM] [] [Loader.Status Storer Module] [] [Processing Status_194d59f476961bd4f04510f0bb6b0d0e_1249396194 937.xml] [] [] [DEBUG] [8/4/09 9:30:20 AM] [] [Loader.Status Storer Module] [] [failed directory size:1768064] [] [] [DEBUG] [8/4/09 9:30:20 AM] [] [Loader.Status Storer Module] [] [Moved Status_194d59f476961bd4f04510f0bb6b0d0e_1249396194 937.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:31:50 AM] [] [Loader.Status Storer Module] [] [Processing Status_488000110f3c7d43b318bc49c7aecca2_1249396293 406.xml] [] [] [DEBUG] [8/4/09 9:31:50 AM] [] [Loader.Status Storer Module] [] [Processing Status_c1f956e7e93b594c8404e25478782c07_1249396280 468.xml] [] [] [DEBUG] [8/4/09 9:31:50 AM] [] [Loader.Status Storer Module] [] [Processing Status_db44b8158529bf5031c1597d85530d76_1249396283 593.xml] [] [] [DEBUG] [8/4/09 9:31:50 AM] [] [Loader.Status Storer Module] [] [failed directory size:1770464] [] [] [DEBUG] [8/4/09 9:31:50 AM] [] [Loader.Status Storer Module] [] [Moved Status_db44b8158529bf5031c1597d85530d76_1249396283 593.xml to failed directory.] [] [] [DEBUG] [8/4/09 9:34:02 AM] [] [Loader.QueueRunner] [] [No Handler registered for action ID: 30626, Type: SUBSCRIPTION_DOWNLOAD] [] []

share|improve this question
add comment

5 Answers

I think this has to do with inventory files coming from clients being processed. Storer, and the XML files are the process and the data files for the inventory process.

What rev of ZCM? 10.2 is where you want to be, if possible.

I should suggest posting in the ZCM forum at support.novell.com, while they are not officially supported there are volunteer sysops there, who can help.

share|improve this answer
add comment

Why would the ZCM server be processing inventory from the devices so often? The inventory schedule is set to 3 hours (1.5 for partial).

I'm running ZCM 10.2.

Karl, do you have a contact to the owner of that wiki? I can't seem to find any personal info on the site.

share|improve this answer
    
Looks like jaredljennings@gmail.com based on the whois for his domain. jjennings@datatechnique.com is his work email, but since it's a private request... –  Karl Katzke Aug 5 '09 at 15:49
    
Jared is actually one of the volunteer sysops (I am as well for Identity management and eDirectory stuff). But Shaun Pond is an actual Novell employee in Zen stuff that can help in that forum. –  geoffc Aug 5 '09 at 16:15
    
Each individual machine sends an inventory file, so processing inventory might be often, due to the staggered nature of the rollout to clients. –  geoffc Aug 5 '09 at 16:16
add comment

Wow, this sucks, and it looks like Novell isn't supporting the product very well. No wonder we haven't pushed this product out yet...

The one helpful post I found in Novell's forums besides the clearing-the-queue thing was this one.

This guy's site seems to be pretty helpful... if you can't figure it out, you might get in touch with him directly.

share|improve this answer
add comment

I'm also experiencing this in SLES SP2/ ZCM 10.2.0 / ESX 3.5.4 My VM is running with only one vCPU and the kernel-vmi

So far I've only did a "nice 10" on the DB-process. Not what I want, though.

share|improve this answer
add comment

You must delete old zen 7 imported bundles. Some (maybe many) contain errors that just throw the cycles to the roof. We did this and the cpu usage drop to the floor. kfreise found this out, just forgot to post it!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.