Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some unknown reason, my SBS 2008 port mappings are incorrect!

My SBS 2008 server uses the (static) IP address 192.168.0.10, but important ports (80, 443, 4125) are pointing to 192.168.0.20. My router (NETGEAR WPN824v2) is managed by SBS 2008 and there doesn't seem to be a way to change them via the browser windows (launched from the SBS console, some ports show, but not the one mentioned above), nor the Windows SBS Console application.

How can I either take manual control of the router, or change the incorrect port mappings using the SBS tools?

Update (clarification really): I can access the router directly from the SBS machine (other machines will show me a message saying that the router is managed by 192.168.0.10), but the 3 ports are not listed in the list of forwarded ports. Trying to set them using the browser interface will result in an error message stating that the port is already being forwarded!

Maybe there is a way to set the router to no longer be managed by 192.168.0.10?

Solution: Turn the UPnP functionality off on the Netgear router and voila, I can now control the port mapping on the router again for the 3 ports.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I always skipped that auto-router configuration script in SBS 2008 because I didn't trust it, now I'm glad I did!

Anyway, re-mapping the ports in any Netgear router is fairly straight forward.

To take manual control of your router, you just need to log into the router's web interface (on a computer that is connected directly to the netgear (not via the SBS's DNS) just enter www.routerlogin.net, otherwise enter the router's IP address). The username is usually 'ADMIN' and the default password is just 'password' (I hope you've changed this).

You should see a screen like the following:

Main admin screen

The first thing you will need to do is disable UPnP (Universal Plug'n'Play) as this is the protocol that SBS 2008 uses to configure your router. You will most likely find this under the advanced settings somewhere. Once you have found it, just uncheck it and save the changes.

Then, look for an option called either Port Forwarding, Port Triggering or Firewall Rules. In there you should see your port mappings:

Port Forwarding

Find the entry you want and click Edit. Then change the IP address from .20 to .10 under "Server Address" and hit save.

Hopefully it's that simple!

share|improve this answer
    
Thx. The problem is (I should have been more clear) that the Netgear page you show above does not list the 3 ports that I want to change! Therefore I cannot change them using this interface. When I try to do that (say selecting HTTP and assigning it to 192.168.0.10) it will complain that it is already assigned. –  Philipp Schmid Aug 4 '09 at 21:51
    
Ooohh. Try disabling the UPNP functionality. I'm not sure where it's located, but it's probably under advanced or something. –  Mark Henderson Aug 4 '09 at 22:13
    
Is that UPNP functionality in the router, or in SBS 2008? –  Philipp Schmid Aug 4 '09 at 22:47
    
I found the UPnP setting in the Netgear page, unchecked the checkbox, and I am now able to set the port mappings by hand again! Score another one for ServerFault.com! –  Philipp Schmid Aug 4 '09 at 23:06
    
Excellent. I will update my answer to reflect this. –  Mark Henderson Aug 5 '09 at 0:42
show 1 more comment

You're going to need to clarify the question. It is unclear if you are talking about internet facing ports.

You should log onto the web interface of your router (usually by hitting the IP of your router in your browser) and check your port forwarding settings. You'll probably find that ports 80, 443, and 4125 are forwarding to 192.168.0.20 instead of 192.168.0.10 as you desire.

share|improve this answer
    
SBS will attempt to configure routers via UPNP or via known interfaces. I never used it because I didn't trust ut. –  Mark Henderson Aug 4 '09 at 21:10
    
Ah. Thanks for the clarification. I had only used SBS 2003 prior. I will edit my answer accordingly –  Kevin Kuphal Aug 4 '09 at 21:15
    
It's all good. It's designed for newbie sysadmins, but as this question shows it's always better to know how to do it by hand! –  Mark Henderson Aug 4 '09 at 21:18
    
The problem is that the page doesn't show those mappings, and trying to set them explicitly will result in an error message indicating that the port is already forwarded. –  Philipp Schmid Aug 4 '09 at 21:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.