Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does anyone know what make of disk HP are using in their 4TB SATA Midline & why WD RE4 don't work?

So we use D2600 crates with HP 2TB disks, and just buy WD2003FYYS - pop them in old HP caddies. bonus: 5yr warranty, half price of HP.

We just tried a set of 4TB disks WD4000FYYZ, and each time the D2600 is powered up, random disks are labled as failed (different every restart). Odd, as D2600 sees disks and creates arrays fine - it just incorrectly fails disks that on restart.

  1. If anyone knows what disks HP ship, that would be great as we can buy those
  2. Does anyone know if firmware updates for D2600 are likely to make these 4TB disks work in the future, or why the disks might be causing the error. Guess I've a dozen 4TB disks that don't work.

Thanks! Robin

[summary: no answers as of 01/05/2012: My testing indicates non-HP WD2003FYYS work fine in MSA60 an D2600, WD4000FYYZ are seen only in the D2600, but are failed on server-restart (ie work in neither)

share|improve this question
HP can use custom firmware for disk drives. I know that HP are using seagate drives, but with custom firmware. Dell do the same. So, they can add custom attributes to that firmware and hardware accepts only drives with custom attributes. – Guntis Apr 17 '13 at 13:05
Is that Seagate for 4Tb, or generally Guntis? I've seen 1TB Seagate and WD, 2TB seem to gave been WD, and 4TB... unknown model as yet... – robin H Apr 17 '13 at 13:23
Don't be cheap! This issue lies with your controller and not the D2600 at this point. Probably firmware. – ewwhite Apr 17 '13 at 13:41
in my case, i have DL360 G7 with ST9750420AS, controller is P410i – Guntis Apr 17 '13 at 13:46
@robinH You're not buying from the right sources. Nobody pays retail on that gear. Come to Server Fault Chat to learn... – ewwhite Apr 17 '13 at 16:09

This is probably not an intentional failure on HP's part. Since the failed drive changes with reboot, I would more likely suspect a bad firmware interaction between the drives and the controller, which is why the 2TB drive works but the 4TB doesn't. WD would be more motivated to research and fix than HP so I would start there.

Side note: the reason that the fans spin at full speed with certain drive models is that temperature reporting is frequently a broken feature, especially on non-enterprise drives. When the controller/enclosure can't get a reliable reading it errs on the side of caution and spins up the fans.

share|improve this answer

HP was making non-HP drives appear as bad at least three years ago. The controller appears to read the drive firmware and when it finds non-HP code, the drive is failed.

I have made non-HP drives work in a G5 server but when another genuine HP drive failed, the HP tech mentioned the non-HP drive and that he could deny service. He did the repair. The HP drives were Western Digital and we used WD RE4 drives. I tried to change firmware but tool would not "see" the drive as a target.

Also, check that the controller would support a genuine HP 4TB drive. We had to update firmware to allow controller to see what, at the time, was a large drive.

I ahve also seen posts that the non-HP drive causes the fan to run at max speed but have not encountered that or seen definitive info.

I believe Dell is doing this as well.

share|improve this answer
About fan speeds. Yes, i can confirm, that in my hp DL360 G7 server fans run at full speed, because i put two SSD drives in server. In bios can change cooling options and then fans run with half speed. And Integrated Management Log have fallowing message POST Error: 1717-Slot X Drive Array - The Following Drive(s) Are Reporting an Overheated Condition: And drive status all the time is Overheated – Guntis Apr 17 '13 at 13:16
Thanks Dave / Guntis.... will be interesting to see if anyone has had experience of any 4TB drives and this set up... one thing of interest - using 2TB non HP drives (RE4 again) works fine in this and our MSA60s, it is just the 4TB that doesn't. that said, i know the 2TB are the same model as HP use, but not yet whether HP have shipped the 4TB RE4 – robin H Apr 17 '13 at 13:17
Couple of points to add, server is Dl380 G8, and P822 controller, which from what I can gather ought to work with 4TB... – robin H Apr 17 '13 at 13:19
@robin H Is there a firmware update for the controller? BIOS update? – Dave M Apr 17 '13 at 13:21
Dave, yea, there have been - ran the firmware update for everything with the HP SUM software, which checks their online repositry for the latest updates... everthing up to date for last few days so nothing new to fix this... :( – robin H Apr 17 '13 at 13:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.