Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am plan to do some real application, here i finalized to use mysql as a backend. And my question is Currently which MySQL version is stable. Also want the major pitfalls for MySQL 5.5 if MySQL 5.6 is stable. Please share your views here. Any commands would be appreciated.

share|improve this question

closed as not constructive by EEAA, Dave M, dunxd, Bryan, Magellan Apr 18 '13 at 16:09

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Surely all of this should have gone into the mix to help you decide on MySQL. –  Iain Apr 18 '13 at 11:17
    
I don't really understand why you would ask "Currently which MySQL version is stable" and wait for an answer rather than just looking on the MySQL website and getting the answer straight away. –  dunxd Apr 18 '13 at 14:37

1 Answer 1

Use whatever version is in your distro's package repo. Seriously. Unless you have very specific needs that require you to run the absolute newest stable, just use your distribution's packaged MySQL.

share|improve this answer
    
What if he's running an unstable distro? –  user67717 Apr 18 '13 at 11:19
2  
Well then by definition, no MySQL he runs on it will ever be stable. –  EEAA Apr 18 '13 at 11:20
    
What if he's running a stable distro but they push out a bug fix for MySQL. Doesn't the fact that MySQL changed contradict the idea that it is stable? –  user67717 Apr 18 '13 at 11:25
1  
No, not at all. "stable" doesn't mean "immutable". Rather, it means that it had passed the most rigorous battery of tests they can throw at it, and that it has been run by users in the "unstable" branch for some time without any issues. –  EEAA Apr 18 '13 at 11:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.