Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just finished setting up a Debian server but my emails aren't being delivered to hotmail/live emails (they don't even show up in the spam folder).
They are however delivered to Gmail addresses along with a yellow message box saying : this message might not have been sent by email@domain.tld - Learn more Report phishing

I started by putting this spf record in the BIND db file for the domain :

domain.tld. IN TXT "v=spf1 mx mx:mail.domain.tld ip4:xxx.xx.xxx.xx -all"

But that didn't fix it. It seems there's a problem with the $myhostname in the main.cf postfix config file.

Here's what mine looks like :

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
..
myhostname = xx.xxx.xx.xxx.in-addr.arpa

xx.xxx.xx.xxx.in-addr.arpa being my reverse DNS

I can't figure out what's wrong with these settings.
Am i looking at the wrong place ?

share|improve this question
2  
Why would you use an RDNS name as your server's hostname? –  NickW Apr 19 '13 at 13:13
    
Well, i followed a guide and i admit, it made sense. I tried putting the fqdn (returned by hostname --fqdn) but after restarting postfix, an error message appeared. what should i replace it with ? –  Marcellus Wallace Apr 19 '13 at 13:33
    
What error did it give to you? The FQDN should usually correspond to the server's hostname, but it doesn't have to. –  NickW Apr 19 '13 at 13:38
    
I did a mistake, i misspelled the server's hostname. That's what caused the error message. I replaced the RDNS with the FQDN, and the mails are delivered now to the junk folder –  Marcellus Wallace Apr 19 '13 at 14:09
    
Is that good enough? If you set your spf record to be v=spf1 mx -all and set up a proper MX record (and RDNS) you should be able to get the mail into the Inbox! –  NickW Apr 19 '13 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.