Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Quite a strange problem I'm having, basically I type "vagrant up" and I'm immediately presented with:

Gem "Librarian" was not found. Try running `vagrant gem install librarian --no-ri --no-rdoc`

Of course typing the above command (with or without sudo) makes no difference. And in fact librarian is already installed, see the list here:

*** LOCAL GEMS ***

actionmailer (3.2.13)
actionpack (3.2.13)
activemodel (3.2.13, 3.2.12)
activerecord (3.2.13)
activeresource (3.2.13)
activesupport (3.2.13, 3.2.12)
addressable (2.3.4, 2.3.3)
archive-tar-minitar (0.5.2)
arel (3.0.2)
berkshelf (1.1.6)
builder (3.0.4)
bundler (1.3.5)
bunny (0.7.9)
capistrano (2.14.2)
celluloid (0.13.0)
chef (11.4.0, 10.16.2)
childprocess (0.3.9)
chozo (0.6.1)
erubis (2.7.0)
faraday (0.8.7, 0.8.6)
ffi (1.7.0, 1.5.0)
hashie (2.0.3)
highline (1.6.18, 1.6.16)
hike (1.2.2)
hipchat (0.8.0)
httparty (0.11.0, 0.10.2)
i18n (0.6.4, 0.6.1)
ipaddress (0.8.0)
journey (1.0.4)
json (1.7.7, 1.6.1)
librarian (0.1.0)
log4r (1.1.10)
mail (2.5.3)
mime-types (1.22, 1.21)
minitar (0.5.4)
mixlib-authentication (1.3.0)
mixlib-cli (1.3.0)
mixlib-config (1.1.2)
mixlib-log (1.6.0, 1.4.1)
mixlib-shellout (1.1.0)
moneta (0.6.0)
multi_json (1.7.2, 1.7.1)
multi_xml (0.5.3)
multipart-post (1.2.0)
net-http-persistent (2.8)
net-scp (1.0.4)
net-sftp (2.0.5)
net-ssh (2.6.7, 2.2.2)
net-ssh-gateway (1.1.0)
net-ssh-multi (1.1)
ohai (6.16.0)
polyglot (0.3.3)
rack (1.4.5)
rack-cache (1.2)
rack-ssl (1.3.3)
rack-test (0.6.2)
rails (3.2.13)
railsless-deploy (1.1.0, 1.0.2)
railties (3.2.13)
rake (10.0.4)
rdoc (3.12.2)
rest-client (1.6.7)
ridley (0.6.3)
rubygems-bundler (1.1.1)
rvm (1.11.3.7)
solve (0.4.2)
sprockets (2.2.2)
systemu (2.5.2)
thor (0.18.1, 0.16.0)
tilt (1.3.7)
timers (1.1.0)
treetop (1.4.12)
tzinfo (0.3.37)
uuidtools (2.1.3)
vagrant (1.0.7)
vagrant-librarian (0.1.1)
yajl-ruby (1.1.0)

And here is my Gemfile:

source 'https://rubygems.org'

gem 'vagrant'
gem 'librarian'
gem 'vagrant-librarian'
gem "berkshelf", "~>1.1.0"

Does anyone have any ideas on how I can proceed next? I'm really at a loss on how to get this working. I've also tried "bundle update" and "bundle install" but that didn't help.

Note: I'm on OS X 10.8.2 with vagrant 1.0.6 and ruby 1.8.7

Thanks in advance! ~ Josh

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

If you look in Vagrantfile, you'll find that error message. It's a catch-all error for when any exception is raised. If the gem fails to load for any reason, it will send this error message. Since it specifies librarian version 0.0.26, if a different version of the gem is installed, it will fail with the same error.

Fix is to update the Gemfile and specify the librarian version needed:

gem 'librarian', '~> 0.0.26'

Then

bundle update

and finally

vagrant up
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.