Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an ISPConfig 3 setup on Centos 6.3. I am using all of the features including mail on the domains setup but one. One of them is using a secondary mail server (inside the lan, but different server) I have configured the DNS settings with an A - Record for mail pointing to the ip address and an MX - record for mail.example.com, but it is still trying to deliver it on the ISPconfig machine.

I'm lost at this point. I don't know what I could of missed. Anyone who might be able to shed some light on the topic would be greatly appreciated.

P.S. - The external mail server is a Kolab 3 mail server inside the same lan that I a using for testing right now.

share|improve this question
    
From inside the ISPconfig machines? Basically you need to go through the web interface and ensure that the domain is configured with an external mailserver (especially on the second domains, for example the one without www) –  NickW Apr 19 '13 at 15:48
    
Not sure I understand what your asking me to do. I have mydomain.com setup under the sites tab, and in the DNS section. I made a point of not creating an entry under the e-mail tab so that I wouldn't have issues like this. Under the DNS settings I have my A record for mydomain.com 1.1.1.1, www 1.1.1.1, and mail 1.1.1.2 along with my MX mail mail.mydomain.com Is there something else that I have to setup to make ISPConfig know that it's not handling the mail for that domain? –  Paul Murphy Apr 19 '13 at 16:10
    
I remember (this was a little while ago) that in the web interface, that ispconfig used to set up domains as having the ispconfig server as a local mailserver by default. Under the options tab, if you set up the domain as www.mydomain.com, you'd also have to change that option for mydomain.com. –  NickW Apr 19 '13 at 16:25
    
I think I know what your talking about but I do want it to be the local mail server by default. Just this one domain I don't want it to be the mail server for. That is why I assigned the ip of a different mail server in the DNS settings. I just don't know why postfix is not recognizing that I don't want it to act as the MTA for that domain. –  Paul Murphy Apr 19 '13 at 18:12
    
As I said, the settings for local or external mail server are set per every domain (and sometimes for every subdomain) in the web interface. –  NickW Apr 22 '13 at 8:13
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.