Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to stop aptitude from upgrading all my packages to testing or beyond.

I'm running Debian lenny, and generally I want to stick with packages from lenny unless I explicitly say otherwise. For particular features I may upgrade a particular package to a version from testing or experimental, but in general I want to stick to the lenny versions. In my /etc/apt/apt.conf I have uttered

APT::Default-Release "lenny";

and my /etc/apt/preferences is listed below.

Problem: whenever I hit the U key in aptitude, it wants to upgrade all my packages at least to testing.

Question: how can I arrange that the U key in aptitude installs only new versions in lenny, not newer versions from testing or elsewhere?

My /etc/apt/preferences (where I freely admit I don't know what I'm doing) is

Package: *
Pin: release a=stable
Pin-Priority: 900

Package: *
Pin: release a=testing
Pin-Priority: 90

Package: *
Pin: release a=experimental
Pin-Priority: 89

Package: *
Pin: release a=gutsy
Pin-Priority: 88

Package: *
Pin: release a=unstable
Pin-Priority: 50
share|improve this question
    
What's your /etc/apt/sources.list? –  Schof Aug 15 '09 at 1:11

2 Answers 2

up vote 2 down vote accepted

Set APT::Default-Release to "stable", not "lenny". The Release file talks in terms of release stages, not release codenames.

share|improve this answer
    
As of Debian 6.0 (Squeeze), you can use codenames with the APT::Default-Release setting. –  Arrowmaster Feb 5 '11 at 17:38

Check your /etc/apt/sources.list. Try using release codenames.

i.e. deb http://ftp.ie.debian.org/debian/ lenny main contrib non-free

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.