Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just did clean wordpress install and set up its .htaccess like they say i should do :

http://codex.wordpress.org/Using_Permalinks

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

when i try to go to some address in my browser like http://localhost:888/blog/ i get 404 error from server. I dont even get directed by wordpress to wordpess's own 404 page.

When i look up my site's error log:

[Sat Apr 20 10:43:36 2013] [error] [client 127.0.0.1] File does not exist: /home/alan/projects/pin_wp/blog, referer: http://localhost:888/

So this leads me into thinking that i have messed up my virtualhost conf somewhere - since im one big noob in that area:

alan@alan:~/projects/pin_wp$ cat /etc/apache2/sites-enabled/localhost-pinwp 
Listen 888
<VirtualHost *:888>
    ServerAdmin webmaster@localhost

    DocumentRoot /home/alan/projects/pin_wp
    ServerName html

    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/alan/projects/pin_wp>
        Options Indexes FollowSymLinks MultiViews +Includes
        AllowOverride None
        Order allow,deny
        allow from all
        AddOutputFilter INCLUDES .html
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error-pinwp.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access-pinwp.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Could someone please help me fix this issue and point me out what kind of dumb mistakes i've done this time.

Alan

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

well i figured it out with little help.

I changed apache conf from:

<Directory /home/alan/projects/pin_wp>
    Options Indexes FollowSymLinks MultiViews +Includes
    AllowOverride None
    Order allow,deny
    allow from all
    AddOutputFilter INCLUDES .html
</Directory>

to

<Directory /home/alan/projects/pin_wp>
    Options Indexes FollowSymLinks MultiViews +Includes
    AllowOverride all
    Order allow,deny
    allow from all
    AddOutputFilter INCLUDES .html
</Directory>

And everything works now.

Alan

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.