Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've hosted my own website from home on a Vista box. I've got one web app on Tomcat running on port 8080 and another site on IIS7 running on port 8000.

Iam using A DynDns account to keep my ip "static".

I can access the site on port 8080 from any locations with no problems. The site on port 8000 works everywhere apart from my office. I've tried using 4 different locations.

From my office i can telnet port 8080 fine. But telnet on port 8000 always fails.

Can someone give me some tips to identify the problem?

It might also be worth mentioning that the Vista box is configured to use OpenDns.

Thanks

share|improve this question
    
From the Serverfault FAQ "if you paid for that desktop hardware, and it's your personal workstation, it is unlikely that your question is appropriate for Server Fault." –  Brian De Smet Aug 5 '09 at 2:58
    
But...it's a web server... –  Bart Silverstrim Aug 5 '09 at 3:12
    
it's marginal but probably ok –  Jeff Atwood Aug 5 '09 at 3:59

3 Answers 3

up vote 1 down vote accepted

Is your office firewall blocking this? Can you access other external servers on port 8000 from your office?

share|improve this answer

Are you able to run a portscan with something like nmap against your server's IP address to see what shows up and what doesn't, and see if the results are different between your office and the other locations? I'd strongly suspect that someone is firewalling outgoing connections on port 8000.

What happens if you reconfigure your IIS to be externally accessible from another port, like 7500 or 8081?

share|improve this answer

Have you configured a host header on your IIS site? If you have, that might explain why it works externally (fully qualified domain name in the URL) and not locally (where you probably only specify the hostname or IP address in the URL).

Either remove the host header altogether (and just use the port to identify the site), or add a second host header that corresponds to the address you use internally.

share|improve this answer
    
To clarify both sites works both locally and externally. Just that the site on port 8000 does not work when trying to access it from my office. Apart from that the sites can be accessed anywhere. –  Th3Fix3r Aug 5 '09 at 2:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.