Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have downloaded the .sh bundle of Glassfish 3.1.2 on my mac machine and started the server using ./asadmin stat-domainand tried to hit the url http://localhost:4848/

but the page is loading forever, i try refreshing the page too but no luck

here is my java configuration on my mac machine

java version "1.6.0_22"

Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)

Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)

i have set my JAVA_HOME too before i have installed glassfish


following is the server.log i dont know what i am missing here

    at javax.xml.parsers.SAXParser.parse(
    at com.sun.enterprise.deployment.archivist.Archivist.readStandardDeploymentDescriptor(
    at com.sun.enterprise.deployment.archivist.Archivist.readDeploymentDescriptors(
    at com.sun.enterprise.deployment.archivist.ApplicationFactory.openArchive(
    at org.glassfish.javaee.core.deployment.DolProvider.load(
    at org.glassfish.javaee.core.deployment.DolProvider.load(
    at com.sun.enterprise.v3.server.ApplicationLifecycle.loadDeployer(
    at com.sun.enterprise.v3.server.ApplicationLifecycle.setupContainerInfos(
    at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(
    at com.sun.enterprise.v3.server.ApplicationLoaderService.processApplication(
    at com.sun.enterprise.v3.admin.adapter.InstallerThread.load(
Caused by: Schema factory class does not extend from SchemaDVFactory.
    ... 25 more
share|improve this question

Did you try to disable all network connections on your mac and then retry to surf to http://localhost:4848/? This could indicate problems with the JVM. (Too low rep to comment)

share|improve this answer

Which browser are you using? I've had no end of problems with glassfhish's admin console "not loading" on the mac version of safari and chrome. It loaded fine in firefox, though. Also, depending on instructions did you enable secure-admin? If you did it'd be https, not http.

share|improve this answer
i have tried it on all the browsers but the result is same , can u tell me that how would i make secure-admin enable – Hunt May 15 '13 at 11:50
asadmin change-admin-password and then asadmin enable-secure-admin then connect with https – chylarides May 15 '13 at 14:01
Also, try downloading the Oracle JDK and using it as JAVA_HOME instead. Download Oracle Java – chylarides May 15 '13 at 14:03
Another thing, do a netstat -an|grep 4848 and see if it's even listening? – chylarides May 15 '13 at 14:06
but does Oracle JDK 7 work on 10.6.8 ? – Hunt May 17 '13 at 5:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.