Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting below error while using yum on Amazon linux in Ec2 server , I am installing openssl-devel package needed to compile nrpe plugin for Nagios.

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for libsepol which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libsepol of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libsepol.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libsepol installed, but
        yum can only see an upgrade for one of those arcitectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libsepol installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

   Protected multilib versions: libsepol-2.1.7-3.12.amzn1.i686 != libsepol-2.1.8-2.12.amzn1.x86_64

You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

I tried everything like

  yum clean all
  yum update
  yum complete transactions

still no luck any help will be appreciated.

share|improve this question
    
I solved this issue by downgrading libsepol package yum downgrade libsepol. –  Abhishek Anand Amralkar May 1 '13 at 10:47
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.