Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install chef-server on a Fedora 18 aws small instance. The first steps that I have done are the following:

yum update
rpm -Uvh http://rbel.frameos.org/rbel6

With the intention of bring the Fedora 18 instance up to the latest updates and installing the repo from which I will install the chef-server from.

The next step I did was the following:

yum --disablerepo="*" --enablerepo="rbel6" install rubygem-chef-server

Which causes me the following problem which I will be needing your assistance in. Note that I am purposely disabling the other repos because it would appear that some of the packages that are outdated versions that don't seem to be available from the fedora repo.

Error: Package: rubygem-chef-server-0.10.6-1.el6.noarch (rbel6)
       Requires: java-1.6.0-openjdk
Error: Package: couchdb-0.11.2-2.el6.x86_64 (rbel6)
       Requires: libicudata.so.42()(64bit)
Error: Package: rubygem-chef-server-0.10.6-1.el6.noarch (rbel6)
       Requires: libxml2-devel
Error: Package: rubygem-chef-server-0.10.6-1.el6.noarch (rbel6)
       Requires: ntp
Error: Package: ruby-libs-1.8.7.352-4.el6.x86_64 (rbel6)
       Requires: libdb-4.7.so()(64bit)
Error: Package: erlang-R12B-5.10.el6.x86_64 (rbel6)
       Requires: tk
Error: Package: couchdb-0.11.2-2.el6.x86_64 (rbel6)
       Requires: libicuuc.so.42()(64bit)
Error: Package: rubygem-chef-server-0.10.6-1.el6.noarch (rbel6)
       Requires: java-1.6.0-openjdk-devel
Error: Package: ruby-libs-1.8.7.352-4.el6.x86_64 (rbel6)
       Requires: libgdbm.so.2()(64bit)
Error: Package: couchdb-0.11.2-2.el6.x86_64 (rbel6)
       Requires: libicui18n.so.42()(64bit)
Error: Package: erlang-R12B-5.10.el6.x86_64 (rbel6)
       Requires: libodbc.so.2()(64bit)

After dealing with the dependencies that I could easily resolve:

yum install ntp
yum install tx
yum install libxml2-devel

After running the command : yum install 'libodbc.so.2' and successfully installing the package :

yum install 'libodbc.so.2'
Package unixODBC-2.3.1-2.fc18.i686 already installed and latest version

I am still getting the error message:

Error: Package: erlang-R12B-5.10.el6.x86_64 (rbel6)
       Requires: libodbc.so.2()(64bit)

I am not sure why I am getting this error and I would appreciate any help in explaining the issue to me and helping me resolve it.

The other packages were not in the fedora repo so I googled for the rpms, downloaded them using wget, and installed them using yum install (if there is a better way to do this please tell me because it can be a pain, esp when there may be more dependencies):

wget ftp://rpmfind.net/linux/fedora/linux/releases/18/Everything/x86_64/os/Packages/u/unixODBC-2.3.1-2.fc18.i686.rpm
yum install unixODBC-2.3.1-2.fc18.i686.rpm
wget ftp://ftp.muug.mb.ca/mirror/fedora/linux/updates/16/x86_64/java-1.6.0-openjdk-devel-1.6.0.0-71.1.11.6.fc16.x86_64.rpm
yum install java-1.6.0-openjdk-1.6.0.0-71.1.11.6.fc16.x86_64.rpm
yum install java-1.6.0-openjdk-devel-1.6.0.0-71.1.11.6.fc16.x86_64.rpm

Which leaves me wit this error message after doing all of the above:

Error: Package: erlang-R12B-5.10.el6.x86_64 (rbel6)
       Requires: libodbc.so.2()(64bit)
Error: Package: ruby-libs-1.8.7.352-4.el6.x86_64 (rbel6)
       Requires: libgdbm.so.2()(64bit)
Error: Package: ruby-libs-1.8.7.352-4.el6.x86_64 (rbel6)
       Requires: libdb-4.7.so()(64bit)

I am not sure what I can do about libgdbm since it appears to a core package and is already installed so not sure what it isn't being detected and I haven't tried installing libdb-4.7.so as I want to get the first two issues resolved. Any advice on how I should proceed from here?

P.S. I apologize for the level of details here. I was hoping that someone would look at what I am doing and tell me that there is a better way of doing this since I just learned how to do these kinds of things ad hoc.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I would assume you those packages are looking for 64Bit version of that lib.

So,

'sudo yum search unixODBC'

comes up with this package "unixODBC-2.3.1-2.fc18.x86_64.rpm"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.