Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm working on configuring our existing pool of four hypervisors running XenServer 6.1 to use a separate management network.

Currently the setup is a single link with a public address over which all VM and management traffic flows.

We're working on changing that to

  • An Active/Passive bonded interface for management on a private network
  • A separate Active/Passive bonded interface for VM traffic

I'm trying to figure out what the impact will be on the current environment when I make the change and whether anyone has any tips or best practices on how to do this.

share|improve this question

1 Answer 1

If you bond a active interface you will have a drop in comms to your servers.

I would suggest the following,

  1. Bring up the bonded pair of eth2 and eth3 on all hypervisors.
  2. Ensure that you can ping, etc.
  3. Then create a network on each hypervisor that will be using the new eth2-eth3 bonded pair.
  4. Move a non critical vm to new virtual network switch and start testing.

Once done, do the same with the management network.

That should work without causing too much of disruption.

share|improve this answer
    
That's what we have up right now, but Xen Server has a single interface - whether a bonded pair or not - that it considers its "Management" interface - with DNS configs, etc - that it uses for communication with the pool. From what I've read, changing which interface Xen uses for this can lead to some really weird pool errors. –  poolski Apr 26 '13 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.