Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently we have a apache/plesk problem, it appears when we try to check all the configurations. This is the error log but the strange thing is that "sys_user_id 67" doesn't exist anymore. We deleted that subscription so it appears that it's stuck in some configuration file.

Here's our Plesk Configuration Log

[2013-04-25 02:41:50][INFO] ==> Installed Plesk version/build: 11.0.9 CentOS 6 110120608.16

[2013-04-25 02:41:50][INFO] ==> Detect system configuration
[2013-04-25 02:41:50][INFO] OS: CentOS release 6.3 (Final)
Kernel \r on an \m
[2013-04-25 02:41:50][INFO] Arch: x86_64

[2013-04-25 02:41:50][INFO] ==> Validation of given db password
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> Web server configuration checker version: 1.0.0

[2013-04-25 02:41:50][INFO] ==> STEP 1: Checking for custom configuration templates...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 2: Checking for the JkWorkersFile directive in the Apache configuration...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 3: Checking associations between domains and IP addresses...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 4: Checking for corrupted reference between IP collections and IP addresses...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 5: Checking for links between APS applications and subscriptions...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 6: Checking for the Zend extension declaraion in php.ini...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 7: Check symbolic links for latest virtual host config files... 
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 8: Checking for system users home directories consistency...
[2013-04-25 02:41:50][INFO] There is missing system user's login or home directory for sys_user_id 67 of hosting with www_root in /var/www/vhosts/wanmolen.nl/www/dev1 of domain 
[2013-04-25 02:41:50][INFO] There is missing Document Root directory /var/www/vhosts/wanmolen.nl/www/dev1 for domain on the filesystem for system user 
[2013-04-25 02:41:50][INFO] There is missing system user's login or home directory for sys_user_id 67 of hosting with www_root in /var/www/vhosts/wanmolen.nl/www/dev1/dev1 of domain 
[2013-04-25 02:41:50][INFO] There is missing Document Root directory /var/www/vhosts/wanmolen.nl/www/dev1/dev1 for domain on the filesystem for system user 
[2013-04-25 02:41:50][INFO] There is missing system user's login or home directory for sys_user_id 67 of hosting with www_root in /var/www/vhosts/wanmolen.nl/httpdocs/joomla of domain 
[2013-04-25 02:41:50][INFO] There is missing Document Root directory /var/www/vhosts/wanmolen.nl/httpdocs/joomla for domain on the filesystem for system user 
[2013-04-25 02:41:50][INFO] There is missing system user's login or home directory for sys_user_id 67 of hosting with www_root in /var/www/vhosts/wanmolen.nl/www/dev1/wanmolen of domain 
[2013-04-25 02:41:50][INFO] There is missing Document Root directory /var/www/vhosts/wanmolen.nl/www/dev1/wanmolen for domain on the filesystem for system user 
[2013-04-25 02:41:50][INFO] There is missing Document Root directory /var/www/vhosts/webrichard.nl/subdomains/joomla for domain on the filesystem for system user webrichard
[2013-04-25 02:41:50][WARNING] There are some inconsistencies in the Parallels Plesk Panel system users. Please check http://kb.parallels.com/113490 for solution and log file /root/webserver_configuration_issues.log for details.
[2013-04-25 02:41:50][INFO] Result: Warning

[2013-04-25 02:41:50][INFO] ==> STEP 9: Checking for multiple bootstappers in generated configurations dir...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 10: Checking for records with empty name field in the Configurations table...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 11: Checking for SElinux state...
[2013-04-25 02:41:50][INFO] Result: OK

[2013-04-25 02:41:50][INFO] ==> STEP 12: Checking for nginx ULIMIT value...
[2013-04-25 02:41:50][INFO] Result: OK
share|improve this question
add comment

2 Answers

it's a database inconsistency between tables domains, hosting and sys_users. There is no automated solution, just check this tables by eyes and fix relations.

share|improve this answer
add comment

Please check this url: http://autoinstall.plesk.com/PSA_9.5.3/dist-pkg-FreeBSD-6.1-i386/ports_release/psa/pkg-install

Search for "sys_user_id" shows that installer script is looking for data in database. Maybe user 67 is left in some database table.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.