Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Arima NM46X dual Opteron server that I am attempting to install ESXi 5.1 on. During the loading of the installer, I am receiving the below message:

VMware ESXi 5.1.0 (WMKernel Release Build 799733)

The system has found a problem on your machine and cannot continue.
Unsupported microcode level 0x01000039
Please use microcode patch level 0x01000065 or higher with
AMD Family 10h B3 processors.

Arima appears to be out of business, and BIOS on their website for this machine is v1.08. The server is currently running v1.10.

Has anyone run into this issue or have any suggestions?

Many thanks!

share|improve this question
    
Does the hardware appear on the Hardware Compatibly List? Regardless, it sounds like you're out of luck. You could try older versions, but I doubt it. –  Dan Apr 25 '13 at 20:53
    
@Dan - Unfortunately it is not on the HCL. I was hoping to use this machine to test before purchasing new servers. I found this link after two days of digging on the web: vmwise.com/2010/06/03/things-i-want-to-remember. I'm going to give it a try. Thanks for your response. –  kdawg4 Apr 26 '13 at 16:23

2 Answers 2

up vote 2 down vote accepted

For anyone that runs into the Microcode error on a ESX/i install, below are the steps that I took.

When launching the installer for ESXi 5.1, I entered shift+o and added attribute 'skipMicrocodeCompatCheck'.

Once installed, when vmware is booting, shift+o again and enter attribute 'skipMicrocodeCompatCheck'.

After installation, SSH to the Host machine and run command 'esxcfg-advcfg -k TRUE skipmicrocodecompatcheck'

Note that this should only be done on test or lab machines and not production environments, as systems that do not pass CompatCheck are not supported by VMware.

Source: http://vmwise.com/2010/06/03/things-i-want-to-remember/

Secondary Source (may take some time to load): http://communities.vmware.com/thread/236107?start=0&tstart=0

share|improve this answer

After install click:- shift o, while it's booting up. then type:- skipMicrocodeCompatCheck At the menu hit F2 and select troubleshooting options Enable ESXi shell ALT F1, and put your username and password in or just type:- root and hit enter, if you haven't already set the password up. type:- esxcfg-advcfg -k TRUE skipmicrocodecompatcheck Then check that the change has been made using vi, type:- vi /etc/vmware/esx.conf look for this line in the file:-

/vmkernel/skipMicrocodeCompatCheck = "TRUE"

If it is great, now we have to save the change from memory to disk, run:-

/sbin/auto-backup.sh /etc/vmware/esx.conf

then reboot (the machine will reboot eventually and no more entering the skipmicrocodecompatcheck at bootup.

reference this article on how the esxi shell operates:-

So why does editing files in ESXi filesystem not persisted across system reboots? The reason for this is ESXi uses an in-memory filesystem. For more details, check out The

Architecture of VMware ESXi whitepaper by VMware. As I mentioned earlier, the persistence of files will depend on what was updated as there are exceptions to the rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.