Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed php 5.4.9 with iis 7.5 on Windows server 2008 R2 with web platform installer.

phpinfo() is working file. But when i upload our web pages getting error. Here I've attached error message. Please advice me about this issue.

I've checked Handler mappings. All are here are default settings only.

enter image description here

share|improve this question
    
Your tags are mutually exclusive: windows 2008 runs IIS 7 and windows Vista runns IIS 7.5 –  Stephane Apr 26 '13 at 12:39
    
@Stephane I coudn't get you –  Kumar Apr 26 '13 at 12:47
    
What version of IIS are you running exactly ? What version of windows exactly ? Because you cannot be running IIS 7.5 on Windows 2008 –  Stephane Apr 26 '13 at 13:02
    
See this for a list of IIS version compared to Windows versions: support.microsoft.com/kb/224609 –  Stephane Apr 26 '13 at 13:08
    
@Stephane I'm using Windows server 2008 R2 Standard and IIS 7.5 –  Kumar Apr 26 '13 at 13:14
add comment

2 Answers 2

Check the default document: in your screenshot, you're not specifying any PHP file, just a path.

More detailed explanation:

By default, no modern web server will just serve a directory listing when the user doesn't specify a document but just a path (e.g. http://www.mysite.org/somefolder/) so they all have a parameter that specify what document in a folder should be considered the default one to serve if the URL isn't specific.

In IIS 7.5 (running on Windows 2008R2), that list is, by default, in this order:

default.htm default.asp index.htm index.html iisstart.htm default.aspx

So either try to access to you main page explicitely http://www.mysite.org/somefolder/index.php) or add it to the list of default documents.

share|improve this answer
    
If we didn't specify anything it'll be look index.html , index.php like this. I hope that i understand your reply... –  Kumar Apr 26 '13 at 12:49
add comment
up vote 0 down vote accepted

Finally I found some error on my web config file. Once I cleared, it's working fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.