Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Exchange Server 2013 and I am trying to connect using Outlook 2010. Both are running on the same server. The Outlook installation is just for testing mailboxes.

Outlook first refused to connect because the network adapter didn't have a default gateway and apparently Outlook requires a default gateway to connect to 127.0.0.1.

Now the network adapter has a default gateway and Outlook continues to pretend that it cannot find the Exchange server.

The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.

This happens regardless of whether I use the Exchange server's name ("exchange") or its (fixed) IP address or "localhost" or 127.0.0.1.

What am I doing wrong?

Update:

After that error message, this small window appears with a slightly different error message.

enter image description here

For some reason Outlook cannot "resolve" the name 127.0.0.1. The same message appears when I try any other name or IP address that points to this same local server including localhost and the server's name and the server's IP address in 192.168.0.0/24.

share|improve this question
    
Is there any other way to test an Exchange installation other than with Outlook? I am thinking this is more of an Outlook issue. –  Andrew J. Brehm May 2 '13 at 20:35
    
Outlook installed on the Exchange Server? Im not sure about 2013, but that used to be a worse-practice in previous versions. –  Greg Askew May 2 '13 at 22:54
    
Same thing happens with Outlook on another machine in the same domain, then with both IP address and name of the Exchange server. –  Andrew J. Brehm May 3 '13 at 0:49
    
I always find Outlook is happier if you use the proper FQDN for the exchange server (e.g. exchange.ad.mycompany.com). Make sure the machine can ping it first. If the client (especially if it's the server itself) can't resolve the FQDN you've got more basic problems). Always amazes me how complex and awkward Microsoft's protocols are. –  USD Matt May 3 '13 at 10:35
    
I can ping the Exchange server using IP address, host name and FQDN. But Outlook still claims it cannot resolve the name. –  Andrew J. Brehm May 3 '13 at 15:53
add comment

4 Answers

first of all, are you using a proxy server in IE? Those tend to mess things up quite a bit. Secondly, could you tell me what kind of output you get from right clicking the outlook icon in the task tray (next to the clock :)) and performing a "test e-mail autoconfiguration"? Uncheck both guesssmart boxes...

This will try and connect to the autodiscover website (localhost/autodiscover/autodiscover.xml) to get the URLS for the services.

share|improve this answer
    
No, there is no proxy server configured. In fact nothing is configured. The server doesn't even have Internet access. There is no Outlook icon in the tray. When I start Outlook it asks me to configure a profile and that's the part that doesn't work as I explained above. –  Andrew J. Brehm May 2 '13 at 20:20
add comment

Exchange 2013 uses RPC over http rather than MAPI, on "Connection Settings" try setting up the RPC settings.

share|improve this answer
    
What "Connection Settings"? –  Andrew J. Brehm May 3 '13 at 15:54
    
I found a "More Settings" button and a Connection tab. There is an option "Connect to Microsoft Exchange using HTTP" under "Outlook Anywhere". I activated it but nothing changes I am still getting the same name resolution error message. –  Andrew J. Brehm May 3 '13 at 16:15
add comment

Use your active directory dns domain.

share|improve this answer
    
More detail would make this a better answer. –  Dave M May 3 '13 at 13:06
add comment
up vote 0 down vote accepted

Found it! It was so easy...

This site had the answer.

http://www.msoutlook.info/question/531

Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider 
Value name: DS Server 
Value type: REG_SZ 
Value: FQDN of the GC server

Apparently the global catalog server (I have only one domain controller for the root domain and it is running as it is also the DNS) was missing.

Once I added its name to the "DS Server" value, the connection works!

But why Outlook needs the global catalog server to resolve a DNS name when DNS is working I don't know.

share|improve this answer
    
And why Outlook cannot find the global catalog server without knowing its name is a bit of a riddle too. –  Andrew J. Brehm May 3 '13 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.