Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Due to a critical personnel shortage, I (not a willing sysadmin!) have been given a RHEL 6.1 VM image with the request that it be migrated to a server running Windows Server 2012 with HyperV. The image came to me as an ISO, so I think it's from VMWare. I did some work and got the VM running. I can access it just fine while logged into the hosting server. However, I'm having trouble enabling eth0 on it. Right now there's only a loopback on it.

I did some research and saw that most people were able to resolve the issue by deleting /etc/udev/rules.d/70-persistent-net I tried that and restarted the VM. No luck.

After several more false starts, I copied the ifcfg-eth0 file from

/etc/sysconfig/networking/devices/

to

/etc/sysconfig/network-scripts/

I manually set the MAC address in this file to what I saw in the HyperV Advanced Options for the Network Adapter. The MAC address is "Dynamic" in this context.

Along the way, after every change I ran service network restart and after I copied the ifcfg-eth0 file I started seeing this message:

no device found for connection 'System eth0'

If I run lspci -m, nothing resembling a NIC shows up. I only see a host bridge, an ISA bridge, and IDE interface, an ACPI bridge, and a virtual VGA controller.

Based on all of this it seems that the VM doesn't recognize the adapter that Windows Server 2012 is trying to provide. I've tried adding and removing the adapter several times from Hyper V, but I haven't seen any changes as a result. One thing I noticed is that the 70-persistent-net file hasn't shown up in the rules.d folder since I first deleted it.

How should I proceed from here? My objective at this point is just to get RHEL on the VIM recognizing the NIC provided by Windows Server 2012.

EDIT: For those who see this later, here is what I had to do.

1.) Shut down the VM 2.) Remove the Network Adapter 3.) Add a "legacy network adapter." 4.) Reboot the VM and type ifconfig -a 5.) If there is currently no config file for the new network interface, create one by copying an existing file in /etc/sysconfig/network-scripts/. For example, I had a new eth1 interface, so I created the config file by copying /etc/sysconfig/network-scripts/ifcfg-eth0 to /etc/sysconfig/network-scripts/ifcfg-eth1 6.) Edit the config file, making sure that the interface names and MAC ID are correct. 7.) system network restart to load the new configuration.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Is this any use to you? http://unix.stackexchange.com/a/17935

(CentOS is derived from RedHat so it could well apply, and apart from that link, the other question/comments/answers in that thread might also be useful).

share|improve this answer
    
YES! This got me on the right path. Many thanks! –  DeeDee Apr 30 '13 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.