Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

there's a very weird situation while configuring RDP on one Windows XP SP3 desktop with private IP:

  1. It works on the internal LAN. Other Windows RDP client can access this desktop. Which means the RDP setting is ok.
  2. It can't be accessed from Internet, which means the router could do NAT and access-list incorrectly.
  3. But the same router settings work for many other XP SP3 desktops in the same time, except for this one.

Any suggestion would be very appreciated!

share|improve this question
add comment

6 Answers

  • Are you applying host firewall policies from GPs in AD?. If so, then no need to check at the host's firewall since it should have the same settings as the others.

    • If you do this manually though on every host, and mistakenly setup an internal network scope for accessing this rule, then you'll see this problem IF the network firewall's subnet is not listed there. Basically, RDP/3389 communication will not be visible from the firewall's internal network (if it's out of it's configured range).
  • If the above doesn't help, try showing us your access-list, though same thing, if the other clients are working and are on the same subnet, then you shouldn't be seeing this problem.

share|improve this answer
add comment

What kind of router are you talking about, a Cisco router or a SOHO router like Netgear or Linksys?

How many IP's do you have configured to hit your router on the public side?

If you're using a cisco router you may need to post the configuration to see if there's a rule blocking or dropping the connection first.

If you change your desktop that isn't working so that it has the IP of a machine that is working for RDP connections (that other working machine turned off, of course) then can you access the RDP session from the outside?

share|improve this answer
add comment

Just make sure port TCP 3389 is forwarded to that RDP box.

share|improve this answer
add comment

Double check your firewall settings on the host.

share|improve this answer
add comment

I don't know how is your setup but I would check if the same port isn't "forwarded" to another computer, since you can only do one forward per port on basic (understand home-like) routers.

In other words, it's a bit like if you had to deliver a parcel to someone on 31337, Foo St. but there's 2 houses with that number on the street...

share|improve this answer
add comment

do you have a public ip address and a router with port forwarding enabled sending the requests to the specific pc (on a static ip address)?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.