Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hope we have some Juniper guys around, I have configured a Juniper SSG5 as our main firewall/router the DHCP server set on interface bgroup1 to have a rang from 10.10.10.76 to 10.10.10.210

All clients can get internet access except for 2. We have pluged other laptops into those ports without problems.

The error I am getting is: IP pool of DHCP server on interface bgroup1 is full. Unable to offer IP address to client at xxxxxxxxxxxx

But the pool is not full. There are tons of addresses available. Everytime I release the IP from the DHCP Server it goes to the end of the list and does not get removed. When the client connects, it keeps the same IP even if I clear the DHCP addresses and recreate it. Tried the release on the client side as well.

What could be the issue ?


Yes the Client is getting a DHCP address, Firewall is disabled.

Situation: Previous router was installed and had a hardware failure -> Replaced with Juniper SSG5 configured to mimic the old router configuration -> all clients have no issues only 2.

On our DSN server we cleared out any records pertaining to the clients mac, Cleared all routes and some netsh cmdlets to clear cache and such.

Still no luck. It's odd because I will plug the same client into another router and it will obtain and get on the internet just fine but when connected to juniper it does not connect. I can ping something once then drop packets.

share|improve this question

1 Answer 1

Never ran into this on a Netscreen...but here's the KB article info from Juniper's site:

The following message will occur on the log events if DHCP server is enabled but no IP Pool is specified:

2004-01-27 21:09:48 system alert 00029 IP pool of DHCP server on interface trust is full. Unable to offer IP

Workaround: Specify an IP Pool, and renew the lease from the DHCP client

Is there an IP pool specified properly? Are the exception clients somehow configured with different VLAN tagging on their NICs?

If it truly isn't a client-side issue, consider removing it from bgroup1, saving the config, and then re-adding it back to bgroup1. As always, make sure you are on the recommended ScreenOS version too, it may simply be a bug.

share|improve this answer
    
I have attempted that and i am using the latest version Firmware Version: 6.3.0r13.0 (Firewall+VPN) also the client can resolve google but can not ping.. also client can ping other clients on same subnet but not other subnets.. I am on the same subnet as the other client and still can not ping the client –  Matthew Apr 30 '13 at 15:19
    
the problem client IS getting a DHCP address? Is the problem client running a firewall or a/v firewall that is blocking these connections? Sorry...I thought the issue was that the client wasn't getting an IP at all. –  TheCleaner Apr 30 '13 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.