Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an app pool that recycles every 29 hours, per default. It recycles smoothly 9 times out of 10, and I'm pretty sure the recycle itself is good for the app. Once every couple weeks the recycle does not work. The old worker process dies cleanly and the new worker process starts, but will not serve up content. Recycling the app pool again manually works like a charm. The failed worker process stops and dies cleanly and a second new worker process fires up and serves content perfectly.

I took a crash dump against the failed worker process prior to recycling it, and DebugDiag found nothing to complain about. I tried to dig a little deeper using WinDBG, but mscorsvr/mscorwks is not loaded yet 15 minutes after the new process started. There are 14 threads running (4 async) and 20 pending client connections, but .NET is not even loaded into the process yet.

Any suggestions where to poke and prod to find a root cause on this?

share|improve this question
    
Anything in the httperf.log? –  Jeff Costa Aug 5 '09 at 15:19
    
Timer_ConnectionIdle the usual number of times. Everything else is quiet. Then there's a couple connection-droppeds, probably about the time I restarted the app pool. –  codepoke Aug 5 '09 at 17:24

1 Answer 1

up vote 0 down vote accepted

Hmmm. A little over a year later, I believe this turned out to be an ISAPI filter load problem. If my memory's correct, one procedure is to fire up ProcMon before the App Pool recycle and see what caused the ISAPI load to fail.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.