Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having an issue deploying a report from BIDS to a SharePoint Integrated Report Services Server. I have set up SSRS and everything is successful from the configuration wizard, I am using a Domain Account and not a Network Service account. And I have checked the rsreportserver.config and I don't have RSWindowsNegotiate enabled but I do have RSWindowsNTLM enabled. From the research I have done the RSWindowsNegotiate is usually an issue but since its not in the config file I guess it isn't in this case??

Basically I have 3 servers in my SP 2010 farm, the Web Front End, DB, and SSRS server and I just added SSRS yesterday. The connection for connecting to the farm was successful as were the settings in central admin. I created a new BI Center site in SP2010 and am trying to deploy a simple report to it but it is not working, I keep getting a login prompt and nothing works, I tried the SSRS server admin account and still keep getting prompted...any ideas why this is? What can I do to resolve this?

Thanks for any help!

EDIT: In SP Central Admin my IIS Authentication Settings are set to NTLM not Negotiate.

EDIT #2: Partly solved the issue, I had to use Trusted Account in SP2010 Central Admin rather than Windows Account...now I can deploy my report to the library no problem, but when I try to open the report I get the following error:

"An error has occurred during report processing. (rsProcessingAborted) Cannot impersonate user for data source 'JIRA_DataSource'. (rsErrorImpersonatingUser) This data source is configured to use Windows integrated security. Windows integrated security is either disabled for this report server or your report server is using Trusted Account mode. (rsWindowsIntegratedSecurityDisabled)"

I have configured my data source access in the BIDS to use a username/password rather than integrated or prompt security and the account I gave it is an admin level SQL account I created in SQL Server Management Studio.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.