Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have FreeBSD 9.0-RELEASE-p6 amd64 on board with quagga 0.9.22 (previously it was 0.9.21).

I have 2 peers as my ISP. One provides the traffic to country-based endpoints, the other - to the rest of the world.

When I reboot my FreeBSD router and all daemons are up and running, I can see that something like 10000 prefixes are accepted by bgpd, but they are not available when I do "netstat -rn".

What I need to do, is to clear bgp session with my country provider (first ISP, who gives me cheap country-based traffic) and then everything becomes OK.

Here is my zebra configuration (zebra.conf):

hostname odin.aaa.bbb.ua
password qwerty
enable password qwerty
ip route 194.xxx.yyy.0/24 null0
ip route 178.ttt.sss.0/20 null0
line vty
debug zebra rib
debug zebra kernel
log file /var/log/quagga/zebra.log

And bgbd.conf:

!
! Zebra configuration saved from vty
!   2005/02/28 19:25:21
!
hostname odin.aaa.bbb.ua
password 1234
enable password 1234
!
router bgp 6666
 bgp router-id 194.xxx.yyy.1
!
! Common Uplink
!
neighbor 62.AA.40.165 remote-as 7777
neighbor 62.AA.40.165 ebgp-multihop 255
neighbor 62.AA.40.165 route-map line-out out
!
! UA-IX Uplink
!
neighbor 93.BB.220.61 remote-as 8888
neighbor 93.BB.220.61 route-map SET-PRIO in
neighbor 93.BB.220.61 route-map line-out out
!
! Our Networks to anounce
!
network 194.xxx.yyy.0/24
network 178.ttt.sss.0/20
!
! What Networks to anounce?
!
ip prefix-list mynet seq 10 permit 194.xxx.yyy.0/24
ip prefix-list mynet seq 20 permit 178.ttt.sss.0/20
!
route-map line-out permit 10
 match ip address prefix-list mynet
!
route-map SET-PRIO permit 10
 set local-preference 500
 set weight 1000
!
line vty
!
log file /var/log/quagga/bgpd.log
!

I want to figure out why quagga cannot throw the routes which it accepted through BGP to the routing table of the OS?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.