Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm build app ruby on rails but openssl on my server is old. I need upgrade openssl because openssl certificate verfication failed.

  • OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
  • Centos 5.8

I have tried upgrade openssl to latest version openssl-1.0.1e and restart apache, but still old version

[root] wget http://www.openssl.org/source/openssl-1.0.1e.tar.gz
[root] tar -xvzf openssl-1.0.1e.tar.gz
[root] cd openssl-1.0.1e
[root] ./config
[root] make
[root] make install

Any suggestions about my problem? Thanks!

reference 1

share|improve this question
1  
Did you read the answers to your link? Redhat/CentOS backport any security patches to OpenSSL, if you have installed the latest version from the CentOS reposititories, you have no issues with security. –  NickW May 3 '13 at 10:47
    
Plus, I really doubt the reason your certificate verification failed has anything to do with the age of your OpenSSl. –  NickW May 3 '13 at 10:48
    
see. Not a security issue which I need, but avoid from problem on future if still using old version, or when I have to install some components who require new version from openssl.. and I already use centos version 5.8 and seemed reluctant to upgrade to version 6, because it will take a long time –  anonymousxxx May 3 '13 at 11:06
    
How about you post the error you get from certificate verification? –  NickW May 3 '13 at 11:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.