Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A drive went bad on one of my nodes (actually 3 went bad, but there was no problem replacing the first one). following replacement of the drive,

[root@ MegaCli]# ./MegaCli64 -PDList -aALL | egrep -i "Slot|State"
Slot Number: 0
Firmware state: Online
Foreign State: None
Slot Number: 1
Firmware state: Online
Foreign State: None
Slot Number: 2
Firmware state: Online
Foreign State: None
Slot Number: 3
Firmware state: Online
Foreign State: None
Slot Number: 4
Firmware state: Unconfigured(good), Spun Up
Foreign State: None
Slot Number: 5
Firmware state: Online
Foreign State: None
Slot Number: 6
Firmware state: Online
Foreign State: None
Slot Number: 7
Firmware state: Unconfigured(good), Spun Up
Foreign State: None
Slot Number: 8
Firmware state: Online
Foreign State: None
Slot Number: 9
Firmware state: Online
Foreign State: None
Slot Number: 10
Firmware state: Online
Foreign State: None
Slot Number: 11
Firmware state: Online
Foreign State: None

All well and good, and both 4 and 7 look the same:

[root@ MegaCli]# ./MegaCli64 -PDInfo -PhysDrv[12:4] -aALL

Enclosure Device ID: 12
Slot Number: 4
Device Id: 4
Sequence Number: 5
Media Error Count: 0
Other Error Count: 0
Predictive Failure Count: 0
Last Predictive Failure Event Seq Number: 0
PD Type: SATA
Raw Size: 1.819 TB [0xe8e088b0 Sectors]
Non Coerced Size: 1.818 TB [0xe8d088b0 Sectors]
Coerced Size: 1.817 TB [0xe8b6d000 Sectors]
Firmware state: Unconfigured(good), Spun Up
SAS Address(0): 0x500507601a4000b8
Connected Port Number: 0(path0)
Inquiry Data: WD-WCAY01105459WD2003FYYS-23W0B0 42D0783 42D0786IBM WA35
FDE Capable: Not Capable
FDE Enable: Disable
Secured: Unsecured
Locked: Unlocked
Foreign State: None
Device Speed: 6.0Gb/s
Link Speed: 3.0Gb/s
Media Type: Hard Disk Device

Normally, i just config them and put a file system on them, but:

[root@ MegaCli]# ./MegaCli64 -CfgLDAdd -r0 '[12:04]' -a0

Unconfigured Physical Disk(s).

Exit Code: 0x26

I have check what documentation and troubleshooting i could find, but cannot figure out what i need to do to these disks to make it so that MegaCli can config them.

Any ideas??

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.