Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using apache in Ubuntu 12.04. I set up my apache server using name-based virtual host, but it seems block other port when I want to access other port directly using IP address.

I run

sudo python -m SimpleHTTPServer 88

want to get a simple server, but my browser cannot access port 88, it says'The connection has timed out'. So I am assuming my apache is blocking port 88 because I directly use IP address to visit, not a domain name.

Is there anyway to solve this?

=====================update====================

Problem solved. Because I am using Amazon aws, they have security check for port open. Just need to add a rule for inbound in my aws console.

Thanks

share|improve this question

1 Answer 1

Most likely the port is blocked by the firewall. Port 88 is nonstandard and should not be enabled by default.

On Ubuntu, if ufw is used, you can enable connections to port 88 with:

sudo ufw allow 88

Or see the full documentation: https://help.ubuntu.com/12.04/serverguide/firewall.html

share|improve this answer
    
I tried that, but it still does not work. Cannot access the port. –  Jiechao Li May 4 '13 at 20:22
    
Problem solved. Thanks anyway. –  Jiechao Li May 4 '13 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.