Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to logon to my Ubuntu (12.04 LTS) server via WinSCP or sftp. There was previously a permission problem for ssh_host_* files in /etc/ssh. This was after I tried chmod -R from another directory, which has apparently changed permissions for some other files too.

I tried sftp -P port-vv username@serverip, which has the below output.

debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
Authenticated to ***** 
debug2: fd 4 setting O_NONBLOCK
debug1: channel 0: new [client-session]
debug2: channel 0: send open
debug1: Requesting
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug2: fd 3 setting TCP_NODELAY
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug2: channel 0: request env confirm 0
debug1: Sending subsystem: sftp
debug2: channel 0: request subsystem confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: subsystem request accepted on channel 0
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype reply 0
debug2: channel 0: rcvd eow
debug2: channel 0: close_read
debug2: channel 0: input open -> closed
debug2: channel 0: rcvd eof
debug2: channel 0: output open -> drain
debug2: channel 0: obuf empty
debug2: channel 0: close_write
debug2: channel 0: output drain -> closed
debug2: channel 0: rcvd close
debug2: channel 0: almost dead
debug2: channel 0: gc: notify user
debug2: channel 0: gc: user detached
debug2: channel 0: send close
debug2: channel 0: is dead
debug2: channel 0: garbage collecting
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
Transferred: sent 1952, received 1960 bytes, in 0.3 seconds
Bytes per second: sent 6473.8, received 6500.3
debug1: Exit status 141
share|improve this question
I don't think this could be answered without seeing the server side logs. What is written to /var/log/auth.log when you try to log in? – kasperd Dec 21 '15 at 21:35
  • Make sure your ~/.profile (or your particular shell's equivalent) does not generate any output.

  • Make sure sshd_config is pointing to a valid sftp binary

share|improve this answer
how to check above points – sajith May 6 '13 at 16:26
You'll have to SSH in first; look in sshd_config and make sure the sftp binary it's referring to exists, is executable, etc. As for the former, check your .profile - or whatever your shell uses in place of it. If you're not sure what anything there does, you can try renaming the file and try again, see if the problem is resolved. – TML May 6 '13 at 16:37

To reset file permission,I used the following link,it successfully changed all permission to its default

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.