Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to create a local share of a directory on a dedicated Windows 2003 server that I'm renting, but when I type the command "net share ..." I get the following error:

"The service name is invalid."

The detailed error message says "You tried to start a service that is not configured on this sytem."

Why would basic net share functionality be disabled on my machine? Is there a service I need to start? Is there another way to create a local share? (That is, I need to create a directory that looks like a network share to an application on this same machine.)

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

Check to see if the Server service (LanmanServer) exists and is started.

If it does exist and is not started then try starting it. If it fails to start then check the event log to see if it gives a reason.

Also check that Startup Type is Automatic.

share|improve this answer
    
Lanmanserver is not in the Services list, and when I try to run "net start lanmanserver" I get the same "The service name is invalid" error. –  ep4169 Aug 5 '09 at 21:27
    
Try installing (or uninstalling, reinstalling) "File and Printer Sharing for Microsoft Networks" for your network connection. (Right click 'My Network Connections' on the desktop and choose properties, or start it from the Control Panel) –  PaulPlum Aug 5 '09 at 22:18
    
Had to take a more roundabout route to installing the File and Printer Sharing, but it worked! –  ep4169 Aug 6 '09 at 18:11
add comment

Net Start is the command to start a service, nothing to do with file sharing. If you trying to share a file form teh command prompt you want to use Net Share, for example:

net share DataShare=c:\Data

Will share c:\data as DataShare.

share|improve this answer
    
Thanks, Sam, I'm an idiot. I accidentally typed "net start..." when I meant to type in "net share...". I have corrected that above. –  ep4169 Aug 5 '09 at 20:51
    
Ok, but the error message you get does seem to relate to net start. If you just type "net share" do you get a list of shares on the server, or an error? –  Sam Aug 5 '09 at 20:57
    
I get the error message listed above. –  ep4169 Aug 5 '09 at 21:26
add comment

You need to first set the config use a logon script or .bat file with the below codelines

:reset server service
sc config lanmanserver start= auto
net start lanmanserver
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.